1DESCRIPTION = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications."
2HOMEPAGE = "https://www.khronos.org/vulkan/"
3BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Samples/issues"
4LICENSE = "Apache-2.0"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a"
7
8SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git;branch=master;protocol=https \
9           file://0001-CMakeLists.txt-do-not-hardcode-lib-as-installation-t.patch \
10           file://debugfix.patch \
11           "
12
13UPSTREAM_CHECK_COMMITS = "1"
14SRCREV = "28ca2dad83ceb157386e0708f5151ae89c177ad4"
15
16UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
17S = "${WORKDIR}/git"
18
19REQUIRED_DISTRO_FEATURES = 'vulkan'
20COMPATIBLE_HOST = "(x86_64|aarch64|mips64|powerpc64|riscv64).*-linux"
21
22inherit cmake features_check
23
24FILES:${PN} += "${datadir}"
25
26#
27# There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths
28# used for logging with LOGE in the code. We need to make this match the value we use
29# in the debug source remapping from CFLAGS
30#
31EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/"
32# Binaries built with PCH enabled don't appear reproducible, differing results were seen
33# from some builds depending on the point the PCH was compiled. Disable it to be
34# deterministic
35EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON"
36
37# This needs to be specified explicitly to avoid xcb/xlib dependencies
38EXTRA_OECMAKE += "-DVKB_WSI_SELECTION=D2D"
39