1DESCRIPTION = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications."
2HOMEPAGE = "https://www.khronos.org/vulkan/"
3BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Samples/issues"
4LICENSE = "Apache-2.0"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a"
7
8SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git;branch=master;protocol=https;lfs=0 \
9           file://0001-CMakeLists.txt-do-not-hardcode-lib-as-installation-t.patch \
10           file://debugfix.patch \
11           file://0001-Qualify-move-as-std-move.patch;patchdir=third_party/spirv-cross \
12           file://0001-Do-not-use-LFS64-functions-on-linux-musl.patch;patchdir=third_party/spdlog \
13           "
14
15UPSTREAM_CHECK_COMMITS = "1"
16SRCREV = "8b945bebf8b2fd987dcf0eeca048068adf4ea44d"
17
18UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
19S = "${WORKDIR}/git"
20
21REQUIRED_DISTRO_FEATURES = 'vulkan'
22COMPATIBLE_HOST = "(x86_64|aarch64|mips64|powerpc64|riscv64).*-linux"
23
24inherit cmake features_check
25
26FILES:${PN} += "${datadir}"
27
28#
29# There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths
30# used for logging with LOGE in the code. We need to make this match the value we use
31# in the debug source remapping from CFLAGS
32#
33EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/"
34# Binaries built with PCH enabled don't appear reproducible, differing results were seen
35# from some builds depending on the point the PCH was compiled. Disable it to be
36# deterministic
37EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON"
38
39# This needs to be specified explicitly to avoid xcb/xlib dependencies
40EXTRA_OECMAKE += "-DVKB_WSI_SELECTION=D2D"
41