1SUMMARY = "VirGL virtual OpenGL renderer"
2DESCRIPTION = "Virgil is a research project to investigate the possibility of \
3creating a virtual 3D GPU for use inside qemu virtual machines, that allows \
4the guest operating system to use the capabilities of the host GPU to \
5accelerate 3D rendering."
6HOMEPAGE = "https://virgil3d.github.io/"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://COPYING;md5=c81c08eeefd9418fca8f88309a76db10"
10
11DEPENDS = "libdrm libepoxy virtual/egl virtual/libgbm"
12SRCREV = "1aeaf5e10a9c89096e96d09599aa419d5c50712f"
13SRC_URI = "git://gitlab.freedesktop.org/virgl/virglrenderer.git;branch=main;protocol=https \
14           file://0001-meson.build-use-python3-directly-for-python.patch \
15           file://0001-vrend-Fix-int-conversion-fatal-build-error-with-GCC-.patch \
16           "
17
18S = "${WORKDIR}/git"
19
20inherit meson pkgconfig features_check
21
22PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'vulkan', 'venus', '', d)}"
23
24PACKAGECONFIG[venus] = "-Dvenus=true,-Dvenus=false,vulkan-loader vulkan-headers"
25PACKAGECONFIG[va] = "-Dvideo=true,-Dvideo=false,libva"
26PACKAGECONFIG[render-server] = "-Drender-server=true,-Drender-server=false"
27PACKAGECONFIG[minigbm_allocation] = "-Dminigbm_allocation=true,-Dminigbm_allocation=false"
28PACKAGECONFIG[venus-validate] = "-Dvenus-validate=true,-Dvenus-validate=false"
29PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,libcheck"
30
31BBCLASSEXTEND = "native nativesdk"
32
33REQUIRED_DISTRO_FEATURES = "opengl"
34