1SUMMARY = "A clock combined with a game of pong"
2LICENSE = "GPLv2+"
3DEPENDS = "virtual/libx11 xdmcp xau"
4
5inherit features_check pkgconfig
6# depends on virtual/libx11
7REQUIRED_DISTRO_FEATURES = "x11"
8
9SRC_URI = "file://pong-clock-no-flicker.c"
10
11LIC_FILES_CHKSUM = "file://pong-clock-no-flicker.c;beginline=1;endline=23;md5=dd248d50f73f746d1ee78586b0b2ebd3"
12
13S = "${WORKDIR}"
14
15do_compile () {
16	${CC} ${CFLAGS} ${LDFLAGS} -o pong-clock pong-clock-no-flicker.c `pkg-config --cflags --libs x11 xau xdmcp`
17}
18
19do_install () {
20	install -d ${D}${bindir}
21	install -m 0755 pong-clock ${D}${bindir}
22}
23