1SUMMARY = "OpenGL driver testing framework"
2DESCRIPTION = "Piglit is an open-source test suite for OpenGL and OpenCL \
3implementations."
4LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
6
7SRC_URI = "git://gitlab.freedesktop.org/mesa/piglit.git;protocol=https \
8           file://0001-cmake-install-bash-completions-in-the-right-place.patch \
9           file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
10           file://0001-Add-a-missing-include-for-htobe32-definition.patch \
11           file://0001-generated_tests-gen_tcs-tes_input_tests.py-do-not-ha.patch \
12           file://0002-tests-util-piglit-shader.c-do-not-hardcode-build-pat.patch \
13           file://0001-serializer.py-make-.gz-files-reproducible.patch \
14           file://0001-framework-profile.py-make-test-lists-reproducible.patch \
15           file://0001-tests-shader.py-sort-the-file-list-before-working-on.patch \
16           "
17UPSTREAM_CHECK_COMMITS = "1"
18
19SRCREV = "0fda9f67a782edec640998286e7b6058e8933d17"
20# (when PV goes above 1.0 remove the trailing r)
21PV = "1.0+gitr${SRCPV}"
22
23S = "${WORKDIR}/git"
24
25X11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
26X11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
27
28DEPENDS = "libpng waffle libxkbcommon virtual/libgl python3-mako-native python3-numpy-native python3-six-native virtual/egl"
29
30inherit cmake pkgconfig python3native features_check bash-completion
31
32# depends on virtual/libgl
33REQUIRED_DISTRO_FEATURES += "opengl"
34
35# The built scripts go into the temporary directory according to tempfile
36# (typically /tmp) which can race if multiple builds happen on the same machine,
37# so tell it to use a directory in ${B} to avoid overwriting.
38export TEMP = "${B}/temp/"
39do_compile[dirs] =+ "${B}/temp/"
40
41PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
42PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
43PACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
44
45export PIGLIT_BUILD_DIR = "../../../../git"
46
47do_configure_prepend() {
48   if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
49        sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
50        sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
51   fi
52}
53
54# Forcibly strip because Piglit is *huge*
55OECMAKE_TARGET_INSTALL = "install/strip"
56
57RDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
58	python3-misc \
59	python3-unixadmin python3-xml python3-multiprocessing \
60	python3-six python3-shell python3-io \
61	python3-netserver bash \
62	"
63
64INSANE_SKIP_${PN} += "dev-so already-stripped"
65
66# As nothing builds against Piglit we don't need to have anything in the
67# sysroot, especially when this is ~2GB of test suite
68SYSROOT_DIRS_remove = "${libdir}"
69
70# Can't be built with ccache
71CCACHE_DISABLE = "1"
72