1SUMMARY = "OpenGL driver testing framework"
2LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4
5SRC_URI = "git://anongit.freedesktop.org/piglit \
6           file://0001-cmake-install-bash-completions-in-the-right-place.patch \
7           file://0001-tests-Use-FE_UPWARD-only-if-its-defined-in-fenv.h.patch \
8           file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
9           "
10UPSTREAM_CHECK_COMMITS = "1"
11
12# From 2018-08-13
13SRCREV = "57859e15dc8ba4034348b04d0b72f213b74d6347"
14# (when PV goes above 1.0 remove the trailing r)
15PV = "1.0+gitr${SRCPV}"
16
17S = "${WORKDIR}/git"
18
19DEPENDS = "libpng virtual/libx11 libxkbcommon libxrender waffle virtual/libgl libglu python3-mako-native python3-numpy-native python3-six-native virtual/egl"
20
21inherit cmake pkgconfig python3native distro_features_check bash-completion
22# depends on virtual/libx11
23REQUIRED_DISTRO_FEATURES = "x11"
24
25# depends on virtual/libgl
26REQUIRED_DISTRO_FEATURES += "opengl"
27
28# The built scripts go into the temporary directory according to tempfile
29# (typically /tmp) which can race if multiple builds happen on the same machine,
30# so tell it to use a directory in ${B} to avoid overwriting.
31export TEMP = "${B}/temp/"
32do_compile[dirs] =+ "${B}/temp/"
33
34PACKAGECONFIG ??= ""
35PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
36
37do_configure_prepend() {
38   if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
39        sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
40        sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
41   fi
42}
43
44OECMAKE_TARGET_INSTALL = "install/strip"
45
46RDEPENDS_${PN} = "waffle python3 python3-mako python3-json \
47	python3-misc \
48	python3-unixadmin python3-xml python3-multiprocessing \
49	python3-six python3-shell python3-io \
50	python3-netserver mesa-demos bash \
51	"
52
53INSANE_SKIP_${PN} += "dev-so already-stripped"
54