1SUMMARY = "OpenGL driver testing framework"
2LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4
5SRC_URI = "git://anongit.freedesktop.org/piglit \
6           file://0001-cmake-install-bash-completions-in-the-right-place.patch \
7           file://0001-tests-Use-FE_UPWARD-only-if-its-defined-in-fenv.h.patch \
8           file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
9           file://format-fix.patch \
10           "
11UPSTREAM_CHECK_COMMITS = "1"
12
13# From 2018-10-26
14SRCREV = "b9066c7717af1d169a616c9e61706b99ff8515b5"
15# (when PV goes above 1.0 remove the trailing r)
16PV = "1.0+gitr${SRCPV}"
17
18S = "${WORKDIR}/git"
19
20DEPENDS = "libpng virtual/libx11 libxkbcommon libxrender waffle virtual/libgl libglu python3-mako-native python3-numpy-native python3-six-native virtual/egl"
21
22inherit cmake pkgconfig python3native distro_features_check bash-completion
23# depends on virtual/libx11
24REQUIRED_DISTRO_FEATURES = "x11"
25
26# depends on virtual/libgl
27REQUIRED_DISTRO_FEATURES += "opengl"
28
29# The built scripts go into the temporary directory according to tempfile
30# (typically /tmp) which can race if multiple builds happen on the same machine,
31# so tell it to use a directory in ${B} to avoid overwriting.
32export TEMP = "${B}/temp/"
33do_compile[dirs] =+ "${B}/temp/"
34
35PACKAGECONFIG ??= ""
36PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
37
38do_configure_prepend() {
39   if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
40        sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
41        sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
42   fi
43}
44
45OECMAKE_TARGET_INSTALL = "install/strip"
46
47RDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
48	python3-misc \
49	python3-unixadmin python3-xml python3-multiprocessing \
50	python3-six python3-shell python3-io \
51	python3-netserver mesa-demos bash \
52	"
53
54INSANE_SKIP_${PN} += "dev-so already-stripped"
55
56# Can't be built with ccache
57CCACHE_DISABLE = "1"
58