1SUMMARY = "OpenGL driver testing framework"
2LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4
5SRC_URI = "git://gitlab.freedesktop.org/mesa/piglit;protocol=https \
6           file://0001-cmake-install-bash-completions-in-the-right-place.patch \
7           file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
8           "
9UPSTREAM_CHECK_COMMITS = "1"
10
11SRCREV = "4294b15e3b84a96f24d1286b73d5832eea267bbf"
12# (when PV goes above 1.0 remove the trailing r)
13PV = "1.0+gitr${SRCPV}"
14
15S = "${WORKDIR}/git"
16
17X11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
18X11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
19
20DEPENDS = "libpng waffle libxkbcommon virtual/libgl python3-mako-native python3-numpy-native python3-six-native virtual/egl"
21
22inherit cmake pkgconfig python3native distro_features_check bash-completion
23
24# depends on virtual/libgl
25REQUIRED_DISTRO_FEATURES += "opengl"
26
27# The built scripts go into the temporary directory according to tempfile
28# (typically /tmp) which can race if multiple builds happen on the same machine,
29# so tell it to use a directory in ${B} to avoid overwriting.
30export TEMP = "${B}/temp/"
31do_compile[dirs] =+ "${B}/temp/"
32
33PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
34PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
35PACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
36
37
38do_configure_prepend() {
39   if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
40        sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
41        sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
42   fi
43}
44
45OECMAKE_TARGET_INSTALL = "install/strip"
46
47RDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
48	python3-misc \
49	python3-unixadmin python3-xml python3-multiprocessing \
50	python3-six python3-shell python3-io \
51	python3-netserver bash \
52	"
53
54INSANE_SKIP_${PN} += "dev-so already-stripped"
55
56# Can't be built with ccache
57CCACHE_DISABLE = "1"
58