1*eb8dc403SDave CobbleySUMMARY = "OpenGL driver testing framework"
2*eb8dc403SDave CobbleyLICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3*eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4*eb8dc403SDave Cobbley
5*eb8dc403SDave CobbleySRC_URI = "git://anongit.freedesktop.org/piglit \
6*eb8dc403SDave Cobbley           file://0001-cmake-install-bash-completions-in-the-right-place.patch \
7*eb8dc403SDave Cobbley           file://0001-tests-Use-FE_UPWARD-only-if-its-defined-in-fenv.h.patch \
8*eb8dc403SDave Cobbley           "
9*eb8dc403SDave CobbleyUPSTREAM_CHECK_COMMITS = "1"
10*eb8dc403SDave Cobbley
11*eb8dc403SDave Cobbley# From 2018-02-26
12*eb8dc403SDave CobbleySRCREV = "4ce0887e2f7f848d2be2e435a2d0f3c80e44ea3b"
13*eb8dc403SDave Cobbley# (when PV goes above 1.0 remove the trailing r)
14*eb8dc403SDave CobbleyPV = "1.0+gitr${SRCPV}"
15*eb8dc403SDave Cobbley
16*eb8dc403SDave CobbleyS = "${WORKDIR}/git"
17*eb8dc403SDave Cobbley
18*eb8dc403SDave CobbleyDEPENDS = "libpng virtual/libx11 libxkbcommon libxrender waffle virtual/libgl libglu python3-mako-native python3-numpy-native python3-six-native virtual/egl"
19*eb8dc403SDave Cobbley
20*eb8dc403SDave Cobbleyinherit cmake python3native distro_features_check bash-completion
21*eb8dc403SDave Cobbley# depends on virtual/libx11
22*eb8dc403SDave CobbleyREQUIRED_DISTRO_FEATURES = "x11"
23*eb8dc403SDave Cobbley
24*eb8dc403SDave Cobbley# depends on virtual/libgl
25*eb8dc403SDave CobbleyREQUIRED_DISTRO_FEATURES += "opengl"
26*eb8dc403SDave Cobbley
27*eb8dc403SDave Cobbley# The built scripts go into the temporary directory according to tempfile
28*eb8dc403SDave Cobbley# (typically /tmp) which can race if multiple builds happen on the same machine,
29*eb8dc403SDave Cobbley# so tell it to use a directory in ${B} to avoid overwriting.
30*eb8dc403SDave Cobbleyexport TEMP = "${B}/temp/"
31*eb8dc403SDave Cobbleydo_compile[dirs] =+ "${B}/temp/"
32*eb8dc403SDave Cobbley
33*eb8dc403SDave CobbleyPACKAGECONFIG ??= ""
34*eb8dc403SDave CobbleyPACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
35*eb8dc403SDave Cobbley
36*eb8dc403SDave Cobbleydo_configure_prepend() {
37*eb8dc403SDave Cobbley   if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
38*eb8dc403SDave Cobbley        sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
39*eb8dc403SDave Cobbley        sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
40*eb8dc403SDave Cobbley   fi
41*eb8dc403SDave Cobbley}
42*eb8dc403SDave Cobbley
43*eb8dc403SDave CobbleyOECMAKE_TARGET_INSTALL = "install/strip"
44*eb8dc403SDave Cobbley
45*eb8dc403SDave CobbleyRDEPENDS_${PN} = "waffle python3 python3-mako python3-json \
46*eb8dc403SDave Cobbley	python3-misc \
47*eb8dc403SDave Cobbley	python3-unixadmin python3-xml python3-multiprocessing \
48*eb8dc403SDave Cobbley	python3-six python3-shell python3-io \
49*eb8dc403SDave Cobbley	python3-netserver mesa-demos bash \
50*eb8dc403SDave Cobbley	"
51*eb8dc403SDave Cobbley
52*eb8dc403SDave CobbleyINSANE_SKIP_${PN} += "dev-so already-stripped"
53