1eb8dc403SDave CobbleySUMMARY = "OpenGL driver testing framework"
2eb8dc403SDave CobbleyLICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4eb8dc403SDave Cobbley
5eb8dc403SDave CobbleySRC_URI = "git://anongit.freedesktop.org/piglit \
6eb8dc403SDave Cobbley           file://0001-cmake-install-bash-completions-in-the-right-place.patch \
7eb8dc403SDave Cobbley           file://0001-tests-Use-FE_UPWARD-only-if-its-defined-in-fenv.h.patch \
81a4b7ee2SBrad Bishop           file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
919323693SBrad Bishop           file://format-fix.patch \
10eb8dc403SDave Cobbley           "
11eb8dc403SDave CobbleyUPSTREAM_CHECK_COMMITS = "1"
12eb8dc403SDave Cobbley
1319323693SBrad Bishop# From 2018-10-26
1419323693SBrad BishopSRCREV = "b9066c7717af1d169a616c9e61706b99ff8515b5"
15eb8dc403SDave Cobbley# (when PV goes above 1.0 remove the trailing r)
16eb8dc403SDave CobbleyPV = "1.0+gitr${SRCPV}"
17eb8dc403SDave Cobbley
18eb8dc403SDave CobbleyS = "${WORKDIR}/git"
19eb8dc403SDave Cobbley
20*c342db35SBrad BishopX11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
21*c342db35SBrad BishopX11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
22*c342db35SBrad Bishop
23*c342db35SBrad BishopDEPENDS = "libpng waffle libxkbcommon virtual/libgl python3-mako-native python3-numpy-native python3-six-native virtual/egl"
24eb8dc403SDave Cobbley
251a4b7ee2SBrad Bishopinherit cmake pkgconfig python3native distro_features_check bash-completion
26eb8dc403SDave Cobbley
27eb8dc403SDave Cobbley# depends on virtual/libgl
28eb8dc403SDave CobbleyREQUIRED_DISTRO_FEATURES += "opengl"
29eb8dc403SDave Cobbley
30eb8dc403SDave Cobbley# The built scripts go into the temporary directory according to tempfile
31eb8dc403SDave Cobbley# (typically /tmp) which can race if multiple builds happen on the same machine,
32eb8dc403SDave Cobbley# so tell it to use a directory in ${B} to avoid overwriting.
33eb8dc403SDave Cobbleyexport TEMP = "${B}/temp/"
34eb8dc403SDave Cobbleydo_compile[dirs] =+ "${B}/temp/"
35eb8dc403SDave Cobbley
36*c342db35SBrad BishopPACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
37eb8dc403SDave CobbleyPACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
38*c342db35SBrad BishopPACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
39*c342db35SBrad Bishop
40eb8dc403SDave Cobbley
41eb8dc403SDave Cobbleydo_configure_prepend() {
42eb8dc403SDave Cobbley   if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
43eb8dc403SDave Cobbley        sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
44eb8dc403SDave Cobbley        sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
45eb8dc403SDave Cobbley   fi
46eb8dc403SDave Cobbley}
47eb8dc403SDave Cobbley
48eb8dc403SDave CobbleyOECMAKE_TARGET_INSTALL = "install/strip"
49eb8dc403SDave Cobbley
50a5c52ff0SBrad BishopRDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
51eb8dc403SDave Cobbley	python3-misc \
52eb8dc403SDave Cobbley	python3-unixadmin python3-xml python3-multiprocessing \
53eb8dc403SDave Cobbley	python3-six python3-shell python3-io \
54*c342db35SBrad Bishop	python3-netserver bash \
55eb8dc403SDave Cobbley	"
56eb8dc403SDave Cobbley
57eb8dc403SDave CobbleyINSANE_SKIP_${PN} += "dev-so already-stripped"
5819323693SBrad Bishop
5919323693SBrad Bishop# Can't be built with ccache
6019323693SBrad BishopCCACHE_DISABLE = "1"
61