1eb8dc403SDave CobbleySUMMARY = "OpenGL driver testing framework"
21d80a2eaSBrad BishopDESCRIPTION = "Piglit is an open-source test suite for OpenGL and OpenCL \
31d80a2eaSBrad Bishopimplementations."
490fd73cbSAndrew GeisslerHOMEPAGE = "https://gitlab.freedesktop.org/mesa/piglit"
590fd73cbSAndrew GeisslerBUGTRACKER = "https://gitlab.freedesktop.org/mesa/piglit/-/issues"
6eb8dc403SDave CobbleyLICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
7eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
8eb8dc403SDave Cobbley
996ff1984SBrad BishopSRC_URI = "git://gitlab.freedesktop.org/mesa/piglit.git;protocol=https \
10eb8dc403SDave Cobbley           file://0001-cmake-install-bash-completions-in-the-right-place.patch \
111a4b7ee2SBrad Bishop           file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
126ce62a20SAndrew Geissler           file://0001-Add-a-missing-include-for-htobe32-definition.patch \
1309209eecSAndrew Geissler           file://0001-generated_tests-gen_tcs-tes_input_tests.py-do-not-ha.patch \
1409209eecSAndrew Geissler           file://0002-tests-util-piglit-shader.c-do-not-hardcode-build-pat.patch \
1509209eecSAndrew Geissler           file://0001-serializer.py-make-.gz-files-reproducible.patch \
1609209eecSAndrew Geissler           file://0001-framework-profile.py-make-test-lists-reproducible.patch \
1709209eecSAndrew Geissler           file://0001-tests-shader.py-sort-the-file-list-before-working-on.patch \
18eb8dc403SDave Cobbley           "
19eb8dc403SDave CobbleyUPSTREAM_CHECK_COMMITS = "1"
20eb8dc403SDave Cobbley
21*ac69b488SWilliam A. Kennington IIISRCREV = "6a4be9e9946df310d9402f995f371c7deb8c27ba"
22eb8dc403SDave Cobbley# (when PV goes above 1.0 remove the trailing r)
23eb8dc403SDave CobbleyPV = "1.0+gitr${SRCPV}"
24eb8dc403SDave Cobbley
25eb8dc403SDave CobbleyS = "${WORKDIR}/git"
26eb8dc403SDave Cobbley
27c342db35SBrad BishopX11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
28c342db35SBrad BishopX11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
29c342db35SBrad Bishop
30c342db35SBrad BishopDEPENDS = "libpng waffle libxkbcommon virtual/libgl python3-mako-native python3-numpy-native python3-six-native virtual/egl"
31eb8dc403SDave Cobbley
326dbb316aSBrad Bishopinherit cmake pkgconfig python3native features_check bash-completion
33eb8dc403SDave Cobbley
34eb8dc403SDave Cobbley# depends on virtual/libgl
35eb8dc403SDave CobbleyREQUIRED_DISTRO_FEATURES += "opengl"
36eb8dc403SDave Cobbley
37eb8dc403SDave Cobbley# The built scripts go into the temporary directory according to tempfile
38eb8dc403SDave Cobbley# (typically /tmp) which can race if multiple builds happen on the same machine,
39eb8dc403SDave Cobbley# so tell it to use a directory in ${B} to avoid overwriting.
40eb8dc403SDave Cobbleyexport TEMP = "${B}/temp/"
41eb8dc403SDave Cobbleydo_compile[dirs] =+ "${B}/temp/"
42eb8dc403SDave Cobbley
43c342db35SBrad BishopPACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
44eb8dc403SDave CobbleyPACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
45c342db35SBrad BishopPACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
46c342db35SBrad Bishop
4709209eecSAndrew Geisslerexport PIGLIT_BUILD_DIR = "../../../../git"
48eb8dc403SDave Cobbley
49eb8dc403SDave Cobbleydo_configure_prepend() {
50eb8dc403SDave Cobbley   if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
51eb8dc403SDave Cobbley        sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
52eb8dc403SDave Cobbley        sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
53eb8dc403SDave Cobbley   fi
54eb8dc403SDave Cobbley}
55eb8dc403SDave Cobbley
5682c905dcSAndrew Geissler# Forcibly strip because Piglit is *huge*
57eb8dc403SDave CobbleyOECMAKE_TARGET_INSTALL = "install/strip"
58eb8dc403SDave Cobbley
59a5c52ff0SBrad BishopRDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
60eb8dc403SDave Cobbley	python3-misc \
61eb8dc403SDave Cobbley	python3-unixadmin python3-xml python3-multiprocessing \
62eb8dc403SDave Cobbley	python3-six python3-shell python3-io \
63c342db35SBrad Bishop	python3-netserver bash \
64eb8dc403SDave Cobbley	"
65eb8dc403SDave Cobbley
66eb8dc403SDave CobbleyINSANE_SKIP_${PN} += "dev-so already-stripped"
6719323693SBrad Bishop
6882c905dcSAndrew Geissler# As nothing builds against Piglit we don't need to have anything in the
6982c905dcSAndrew Geissler# sysroot, especially when this is ~2GB of test suite
7082c905dcSAndrew GeisslerSYSROOT_DIRS_remove = "${libdir}"
7182c905dcSAndrew Geissler
7219323693SBrad Bishop# Can't be built with ccache
7319323693SBrad BishopCCACHE_DISABLE = "1"
74