1eb8dc403SDave CobbleySUMMARY = "OpenGL driver testing framework"
21d80a2eaSBrad BishopDESCRIPTION = "Piglit is an open-source test suite for OpenGL and OpenCL \
31d80a2eaSBrad Bishopimplementations."
4eb8dc403SDave CobbleyLICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
5eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
6eb8dc403SDave Cobbley
796ff1984SBrad BishopSRC_URI = "git://gitlab.freedesktop.org/mesa/piglit.git;protocol=https \
8eb8dc403SDave Cobbley           file://0001-cmake-install-bash-completions-in-the-right-place.patch \
91a4b7ee2SBrad Bishop           file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
106ce62a20SAndrew Geissler           file://0001-Add-a-missing-include-for-htobe32-definition.patch \
1109209eecSAndrew Geissler           file://0001-generated_tests-gen_tcs-tes_input_tests.py-do-not-ha.patch \
1209209eecSAndrew Geissler           file://0002-tests-util-piglit-shader.c-do-not-hardcode-build-pat.patch \
1309209eecSAndrew Geissler           file://0001-serializer.py-make-.gz-files-reproducible.patch \
1409209eecSAndrew Geissler           file://0001-framework-profile.py-make-test-lists-reproducible.patch \
1509209eecSAndrew Geissler           file://0001-tests-shader.py-sort-the-file-list-before-working-on.patch \
16eb8dc403SDave Cobbley           "
17eb8dc403SDave CobbleyUPSTREAM_CHECK_COMMITS = "1"
18eb8dc403SDave Cobbley
19*9b4d8b0eSAndrew GeisslerSRCREV = "d4d9353b7290ed22cb7349226a8e4017402d3f02"
20eb8dc403SDave Cobbley# (when PV goes above 1.0 remove the trailing r)
21eb8dc403SDave CobbleyPV = "1.0+gitr${SRCPV}"
22eb8dc403SDave Cobbley
23eb8dc403SDave CobbleyS = "${WORKDIR}/git"
24eb8dc403SDave Cobbley
25c342db35SBrad BishopX11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
26c342db35SBrad BishopX11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
27c342db35SBrad Bishop
28c342db35SBrad BishopDEPENDS = "libpng waffle libxkbcommon virtual/libgl python3-mako-native python3-numpy-native python3-six-native virtual/egl"
29eb8dc403SDave Cobbley
306dbb316aSBrad Bishopinherit cmake pkgconfig python3native features_check bash-completion
31eb8dc403SDave Cobbley
32eb8dc403SDave Cobbley# depends on virtual/libgl
33eb8dc403SDave CobbleyREQUIRED_DISTRO_FEATURES += "opengl"
34eb8dc403SDave Cobbley
35eb8dc403SDave Cobbley# The built scripts go into the temporary directory according to tempfile
36eb8dc403SDave Cobbley# (typically /tmp) which can race if multiple builds happen on the same machine,
37eb8dc403SDave Cobbley# so tell it to use a directory in ${B} to avoid overwriting.
38eb8dc403SDave Cobbleyexport TEMP = "${B}/temp/"
39eb8dc403SDave Cobbleydo_compile[dirs] =+ "${B}/temp/"
40eb8dc403SDave Cobbley
41c342db35SBrad BishopPACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
42eb8dc403SDave CobbleyPACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
43c342db35SBrad BishopPACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
44c342db35SBrad Bishop
4509209eecSAndrew Geisslerexport PIGLIT_BUILD_DIR = "../../../../git"
46eb8dc403SDave Cobbley
47eb8dc403SDave Cobbleydo_configure_prepend() {
48eb8dc403SDave Cobbley   if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
49eb8dc403SDave Cobbley        sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
50eb8dc403SDave Cobbley        sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
51eb8dc403SDave Cobbley   fi
52eb8dc403SDave Cobbley}
53eb8dc403SDave Cobbley
5482c905dcSAndrew Geissler# Forcibly strip because Piglit is *huge*
55eb8dc403SDave CobbleyOECMAKE_TARGET_INSTALL = "install/strip"
56eb8dc403SDave Cobbley
57a5c52ff0SBrad BishopRDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
58eb8dc403SDave Cobbley	python3-misc \
59eb8dc403SDave Cobbley	python3-unixadmin python3-xml python3-multiprocessing \
60eb8dc403SDave Cobbley	python3-six python3-shell python3-io \
61c342db35SBrad Bishop	python3-netserver bash \
62eb8dc403SDave Cobbley	"
63eb8dc403SDave Cobbley
64eb8dc403SDave CobbleyINSANE_SKIP_${PN} += "dev-so already-stripped"
6519323693SBrad Bishop
6682c905dcSAndrew Geissler# As nothing builds against Piglit we don't need to have anything in the
6782c905dcSAndrew Geissler# sysroot, especially when this is ~2GB of test suite
6882c905dcSAndrew GeisslerSYSROOT_DIRS_remove = "${libdir}"
6982c905dcSAndrew Geissler
7019323693SBrad Bishop# Can't be built with ccache
7119323693SBrad BishopCCACHE_DISABLE = "1"
72