1eb8dc403SDave CobbleySUMMARY = "OpenGL driver testing framework"
21d80a2eaSBrad BishopDESCRIPTION = "Piglit is an open-source test suite for OpenGL and OpenCL \
31d80a2eaSBrad Bishopimplementations."
490fd73cbSAndrew GeisslerHOMEPAGE = "https://gitlab.freedesktop.org/mesa/piglit"
590fd73cbSAndrew GeisslerBUGTRACKER = "https://gitlab.freedesktop.org/mesa/piglit/-/issues"
67e0e3c0cSAndrew GeisslerLICENSE = "MIT & LGPL-2.0-or-later & GPL-3.0-only & GPL-2.0-or-later & BSD-3-Clause"
7eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
8eb8dc403SDave Cobbley
9eff27476SAndrew GeisslerSRC_URI = "git://gitlab.freedesktop.org/mesa/piglit.git;protocol=https;branch=main \
10eb8dc403SDave Cobbley           file://0001-cmake-install-bash-completions-in-the-right-place.patch \
111a4b7ee2SBrad Bishop           file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
126ce62a20SAndrew Geissler           file://0001-Add-a-missing-include-for-htobe32-definition.patch \
1309209eecSAndrew Geissler           file://0002-tests-util-piglit-shader.c-do-not-hardcode-build-pat.patch \
14eb8dc403SDave Cobbley           "
15eb8dc403SDave CobbleyUPSTREAM_CHECK_COMMITS = "1"
16eb8dc403SDave Cobbley
177e0e3c0cSAndrew GeisslerSRCREV = "2f80c7cc9c02d37574dc8ba3140b7dd8eb3cbf82"
18eb8dc403SDave Cobbley# (when PV goes above 1.0 remove the trailing r)
19eb8dc403SDave CobbleyPV = "1.0+gitr${SRCPV}"
20eb8dc403SDave Cobbley
21eb8dc403SDave CobbleyS = "${WORKDIR}/git"
22eb8dc403SDave Cobbley
23c342db35SBrad BishopX11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
24c342db35SBrad BishopX11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
25c342db35SBrad Bishop
26*9aee5003SAndrew GeisslerDEPENDS = "libpng waffle libxkbcommon python3-mako-native python3-numpy-native python3-six-native virtual/egl"
27eb8dc403SDave Cobbley
286dbb316aSBrad Bishopinherit cmake pkgconfig python3native features_check bash-completion
29eb8dc403SDave Cobbley
30eb8dc403SDave Cobbley# depends on virtual/libgl
31eb8dc403SDave CobbleyREQUIRED_DISTRO_FEATURES += "opengl"
32eb8dc403SDave Cobbley
33eb8dc403SDave Cobbley# The built scripts go into the temporary directory according to tempfile
34eb8dc403SDave Cobbley# (typically /tmp) which can race if multiple builds happen on the same machine,
35eb8dc403SDave Cobbley# so tell it to use a directory in ${B} to avoid overwriting.
36eb8dc403SDave Cobbleyexport TEMP = "${B}/temp/"
37eb8dc403SDave Cobbleydo_compile[dirs] =+ "${B}/temp/"
38eb8dc403SDave Cobbley
39c342db35SBrad BishopPACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
40eb8dc403SDave CobbleyPACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
41c342db35SBrad BishopPACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
42eff27476SAndrew GeisslerPACKAGECONFIG[vulkan] = "-DPIGLIT_BUILD_VK_TESTS=ON,-DPIGLIT_BUILD_VK_TESTS=OFF,vulkan-loader"
43c342db35SBrad Bishop
4409209eecSAndrew Geisslerexport PIGLIT_BUILD_DIR = "../../../../git"
45eb8dc403SDave Cobbley
46213cb269SPatrick Williamsdo_configure:prepend() {
47eb8dc403SDave Cobbley   if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
48eb8dc403SDave Cobbley        sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
49eb8dc403SDave Cobbley        sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
50eb8dc403SDave Cobbley   fi
51eb8dc403SDave Cobbley}
52eb8dc403SDave Cobbley
5382c905dcSAndrew Geissler# Forcibly strip because Piglit is *huge*
54eb8dc403SDave CobbleyOECMAKE_TARGET_INSTALL = "install/strip"
55eb8dc403SDave Cobbley
56213cb269SPatrick WilliamsRDEPENDS:${PN} = "waffle waffle-bin python3 python3-mako python3-json \
57eb8dc403SDave Cobbley	python3-misc \
58eb8dc403SDave Cobbley	python3-unixadmin python3-xml python3-multiprocessing \
59eb8dc403SDave Cobbley	python3-six python3-shell python3-io \
60c342db35SBrad Bishop	python3-netserver bash \
61eb8dc403SDave Cobbley	"
62eb8dc403SDave Cobbley
63213cb269SPatrick WilliamsINSANE_SKIP:${PN} += "dev-so already-stripped"
6419323693SBrad Bishop
6582c905dcSAndrew Geissler# As nothing builds against Piglit we don't need to have anything in the
6682c905dcSAndrew Geissler# sysroot, especially when this is ~2GB of test suite
67213cb269SPatrick WilliamsSYSROOT_DIRS:remove = "${libdir}"
6882c905dcSAndrew Geissler
6919323693SBrad Bishop# Can't be built with ccache
7019323693SBrad BishopCCACHE_DISABLE = "1"
71