1eb8dc403SDave CobbleySUMMARY = "OpenGL driver testing framework"
2eb8dc403SDave CobbleyLICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4eb8dc403SDave Cobbley
5*96ff1984SBrad BishopSRC_URI = "git://gitlab.freedesktop.org/mesa/piglit.git;protocol=https \
6eb8dc403SDave Cobbley           file://0001-cmake-install-bash-completions-in-the-right-place.patch \
71a4b7ee2SBrad Bishop           file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
8eb8dc403SDave Cobbley           "
9eb8dc403SDave CobbleyUPSTREAM_CHECK_COMMITS = "1"
10eb8dc403SDave Cobbley
11*96ff1984SBrad BishopSRCREV = "f0e868ac6fbdc295b2955c1b8f73169e7a52f938"
12eb8dc403SDave Cobbley# (when PV goes above 1.0 remove the trailing r)
13eb8dc403SDave CobbleyPV = "1.0+gitr${SRCPV}"
14eb8dc403SDave Cobbley
15eb8dc403SDave CobbleyS = "${WORKDIR}/git"
16eb8dc403SDave Cobbley
17c342db35SBrad BishopX11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
18c342db35SBrad BishopX11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
19c342db35SBrad Bishop
20c342db35SBrad BishopDEPENDS = "libpng waffle libxkbcommon virtual/libgl python3-mako-native python3-numpy-native python3-six-native virtual/egl"
21eb8dc403SDave Cobbley
221a4b7ee2SBrad Bishopinherit cmake pkgconfig python3native distro_features_check bash-completion
23eb8dc403SDave Cobbley
24eb8dc403SDave Cobbley# depends on virtual/libgl
25eb8dc403SDave CobbleyREQUIRED_DISTRO_FEATURES += "opengl"
26eb8dc403SDave Cobbley
27eb8dc403SDave Cobbley# The built scripts go into the temporary directory according to tempfile
28eb8dc403SDave Cobbley# (typically /tmp) which can race if multiple builds happen on the same machine,
29eb8dc403SDave Cobbley# so tell it to use a directory in ${B} to avoid overwriting.
30eb8dc403SDave Cobbleyexport TEMP = "${B}/temp/"
31eb8dc403SDave Cobbleydo_compile[dirs] =+ "${B}/temp/"
32eb8dc403SDave Cobbley
33c342db35SBrad BishopPACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
34eb8dc403SDave CobbleyPACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
35c342db35SBrad BishopPACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
36c342db35SBrad Bishop
37eb8dc403SDave Cobbley
38eb8dc403SDave Cobbleydo_configure_prepend() {
39eb8dc403SDave Cobbley   if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
40eb8dc403SDave Cobbley        sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
41eb8dc403SDave Cobbley        sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
42eb8dc403SDave Cobbley   fi
43eb8dc403SDave Cobbley}
44eb8dc403SDave Cobbley
45eb8dc403SDave CobbleyOECMAKE_TARGET_INSTALL = "install/strip"
46eb8dc403SDave Cobbley
47a5c52ff0SBrad BishopRDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
48eb8dc403SDave Cobbley	python3-misc \
49eb8dc403SDave Cobbley	python3-unixadmin python3-xml python3-multiprocessing \
50eb8dc403SDave Cobbley	python3-six python3-shell python3-io \
51c342db35SBrad Bishop	python3-netserver bash \
52eb8dc403SDave Cobbley	"
53eb8dc403SDave Cobbley
54eb8dc403SDave CobbleyINSANE_SKIP_${PN} += "dev-so already-stripped"
5519323693SBrad Bishop
5619323693SBrad Bishop# Can't be built with ccache
5719323693SBrad BishopCCACHE_DISABLE = "1"
58