1eb8dc403SDave CobbleySUMMARY = "OpenGL driver testing framework"
21d80a2eaSBrad BishopDESCRIPTION = "Piglit is an open-source test suite for OpenGL and OpenCL \
31d80a2eaSBrad Bishopimplementations."
4eb8dc403SDave CobbleyLICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
5eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
6eb8dc403SDave Cobbley
796ff1984SBrad BishopSRC_URI = "git://gitlab.freedesktop.org/mesa/piglit.git;protocol=https \
8eb8dc403SDave Cobbley           file://0001-cmake-install-bash-completions-in-the-right-place.patch \
91a4b7ee2SBrad Bishop           file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
10eb8dc403SDave Cobbley           "
11eb8dc403SDave CobbleyUPSTREAM_CHECK_COMMITS = "1"
12eb8dc403SDave Cobbley
13*82c905dcSAndrew GeisslerSRCREV = "6126c2d4e476c7770d216ffa1932c10e2a5a7813"
14eb8dc403SDave Cobbley# (when PV goes above 1.0 remove the trailing r)
15eb8dc403SDave CobbleyPV = "1.0+gitr${SRCPV}"
16eb8dc403SDave Cobbley
17eb8dc403SDave CobbleyS = "${WORKDIR}/git"
18eb8dc403SDave Cobbley
19c342db35SBrad BishopX11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
20c342db35SBrad BishopX11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
21c342db35SBrad Bishop
22c342db35SBrad BishopDEPENDS = "libpng waffle libxkbcommon virtual/libgl python3-mako-native python3-numpy-native python3-six-native virtual/egl"
23eb8dc403SDave Cobbley
246dbb316aSBrad Bishopinherit cmake pkgconfig python3native features_check bash-completion
25eb8dc403SDave Cobbley
26eb8dc403SDave Cobbley# depends on virtual/libgl
27eb8dc403SDave CobbleyREQUIRED_DISTRO_FEATURES += "opengl"
28eb8dc403SDave Cobbley
29eb8dc403SDave Cobbley# The built scripts go into the temporary directory according to tempfile
30eb8dc403SDave Cobbley# (typically /tmp) which can race if multiple builds happen on the same machine,
31eb8dc403SDave Cobbley# so tell it to use a directory in ${B} to avoid overwriting.
32eb8dc403SDave Cobbleyexport TEMP = "${B}/temp/"
33eb8dc403SDave Cobbleydo_compile[dirs] =+ "${B}/temp/"
34eb8dc403SDave Cobbley
35c342db35SBrad BishopPACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
36eb8dc403SDave CobbleyPACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
37c342db35SBrad BishopPACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
38c342db35SBrad Bishop
39eb8dc403SDave Cobbley
40eb8dc403SDave Cobbleydo_configure_prepend() {
41eb8dc403SDave Cobbley   if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
42eb8dc403SDave Cobbley        sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
43eb8dc403SDave Cobbley        sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
44eb8dc403SDave Cobbley   fi
45eb8dc403SDave Cobbley}
46eb8dc403SDave Cobbley
47*82c905dcSAndrew Geissler# Forcibly strip because Piglit is *huge*
48eb8dc403SDave CobbleyOECMAKE_TARGET_INSTALL = "install/strip"
49eb8dc403SDave Cobbley
50a5c52ff0SBrad BishopRDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
51eb8dc403SDave Cobbley	python3-misc \
52eb8dc403SDave Cobbley	python3-unixadmin python3-xml python3-multiprocessing \
53eb8dc403SDave Cobbley	python3-six python3-shell python3-io \
54c342db35SBrad Bishop	python3-netserver bash \
55eb8dc403SDave Cobbley	"
56eb8dc403SDave Cobbley
57eb8dc403SDave CobbleyINSANE_SKIP_${PN} += "dev-so already-stripped"
5819323693SBrad Bishop
59*82c905dcSAndrew Geissler# As nothing builds against Piglit we don't need to have anything in the
60*82c905dcSAndrew Geissler# sysroot, especially when this is ~2GB of test suite
61*82c905dcSAndrew GeisslerSYSROOT_DIRS_remove = "${libdir}"
62*82c905dcSAndrew Geissler
6319323693SBrad Bishop# Can't be built with ccache
6419323693SBrad BishopCCACHE_DISABLE = "1"
65