1eb8dc403SDave CobbleySUMMARY = "OpenGL driver testing framework"
2eb8dc403SDave CobbleyLICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4eb8dc403SDave Cobbley
5eb8dc403SDave CobbleySRC_URI = "git://anongit.freedesktop.org/piglit \
6eb8dc403SDave Cobbley           file://0001-cmake-install-bash-completions-in-the-right-place.patch \
7eb8dc403SDave Cobbley           file://0001-tests-Use-FE_UPWARD-only-if-its-defined-in-fenv.h.patch \
81a4b7ee2SBrad Bishop           file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
9*19323693SBrad Bishop           file://format-fix.patch \
10eb8dc403SDave Cobbley           "
11eb8dc403SDave CobbleyUPSTREAM_CHECK_COMMITS = "1"
12eb8dc403SDave Cobbley
13*19323693SBrad Bishop# From 2018-10-26
14*19323693SBrad BishopSRCREV = "b9066c7717af1d169a616c9e61706b99ff8515b5"
15eb8dc403SDave Cobbley# (when PV goes above 1.0 remove the trailing r)
16eb8dc403SDave CobbleyPV = "1.0+gitr${SRCPV}"
17eb8dc403SDave Cobbley
18eb8dc403SDave CobbleyS = "${WORKDIR}/git"
19eb8dc403SDave Cobbley
20eb8dc403SDave CobbleyDEPENDS = "libpng virtual/libx11 libxkbcommon libxrender waffle virtual/libgl libglu python3-mako-native python3-numpy-native python3-six-native virtual/egl"
21eb8dc403SDave Cobbley
221a4b7ee2SBrad Bishopinherit cmake pkgconfig python3native distro_features_check bash-completion
23eb8dc403SDave Cobbley# depends on virtual/libx11
24eb8dc403SDave CobbleyREQUIRED_DISTRO_FEATURES = "x11"
25eb8dc403SDave Cobbley
26eb8dc403SDave Cobbley# depends on virtual/libgl
27eb8dc403SDave CobbleyREQUIRED_DISTRO_FEATURES += "opengl"
28eb8dc403SDave Cobbley
29eb8dc403SDave Cobbley# The built scripts go into the temporary directory according to tempfile
30eb8dc403SDave Cobbley# (typically /tmp) which can race if multiple builds happen on the same machine,
31eb8dc403SDave Cobbley# so tell it to use a directory in ${B} to avoid overwriting.
32eb8dc403SDave Cobbleyexport TEMP = "${B}/temp/"
33eb8dc403SDave Cobbleydo_compile[dirs] =+ "${B}/temp/"
34eb8dc403SDave Cobbley
35eb8dc403SDave CobbleyPACKAGECONFIG ??= ""
36eb8dc403SDave CobbleyPACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
37eb8dc403SDave Cobbley
38eb8dc403SDave Cobbleydo_configure_prepend() {
39eb8dc403SDave Cobbley   if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
40eb8dc403SDave Cobbley        sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
41eb8dc403SDave Cobbley        sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
42eb8dc403SDave Cobbley   fi
43eb8dc403SDave Cobbley}
44eb8dc403SDave Cobbley
45eb8dc403SDave CobbleyOECMAKE_TARGET_INSTALL = "install/strip"
46eb8dc403SDave Cobbley
47a5c52ff0SBrad BishopRDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
48eb8dc403SDave Cobbley	python3-misc \
49eb8dc403SDave Cobbley	python3-unixadmin python3-xml python3-multiprocessing \
50eb8dc403SDave Cobbley	python3-six python3-shell python3-io \
51eb8dc403SDave Cobbley	python3-netserver mesa-demos bash \
52eb8dc403SDave Cobbley	"
53eb8dc403SDave Cobbley
54eb8dc403SDave CobbleyINSANE_SKIP_${PN} += "dev-so already-stripped"
55*19323693SBrad Bishop
56*19323693SBrad Bishop# Can't be built with ccache
57*19323693SBrad BishopCCACHE_DISABLE = "1"
58