1SUMMARY = "Very simple session manager for X"
2DESCRIPTION = "Simple session manager for X, that provides just the right boilerplate to create a session and launch the browser "
3HOMEPAGE = "http://www.yoctoproject.org"
4BUGTRACKER = "http://bugzilla.pokylinux.org"
5
6
7LICENSE = "GPL-2.0-only"
8LIC_FILES_CHKSUM = "file://mini-x-session;endline=5;md5=b6430bffbcf05f9760e72938826b7487"
9
10SECTION = "x11"
11RCONFLICTS:${PN} = "matchbox-common"
12
13SRC_URI = "file://mini-x-session"
14S = "${WORKDIR}"
15
16RDEPENDS:${PN} = "sudo"
17
18inherit update-alternatives
19
20ALTERNATIVE:${PN} = "x-session-manager"
21ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/mini-x-session"
22ALTERNATIVE_PRIORITY = "50"
23
24do_install() {
25	install -d ${D}/${bindir}
26	install -m 0755 ${S}/mini-x-session ${D}/${bindir}
27}
28