1SUMMARY = "The OpenGL utility toolkit"
2DESCRIPTION = "GLU is a utility toolkit used with OpenGL implementations"
3
4HOMEPAGE = "http://mesa3d.org"
5BUGTRACKER = "https://bugs.freedesktop.org"
6SECTION = "x11"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://include/GL/glu.h;endline=29;md5=6b79c570f644363b356456e7d44471d9 \
9                    file://src/libtess/tess.c;endline=29;md5=6b79c570f644363b356456e7d44471d9"
10
11# Epoch as this used to be part of mesa
12PE = "2"
13
14SRC_URI = "https://mesa.freedesktop.org/archive/glu/glu-${PV}.tar.xz \
15           "
16
17SRC_URI[sha256sum] = "bd43fe12f374b1192eb15fe20e45ff456b9bc26ab57f0eee919f96ca0f8a330f"
18
19S = "${WORKDIR}/glu-${PV}"
20
21DEPENDS = "virtual/libgl"
22
23inherit meson pkgconfig features_check
24
25EXTRA_OEMESON = "-Dgl_provider=gl"
26
27# Requires libGL.so which is provided by mesa when x11 in DISTRO_FEATURES
28REQUIRED_DISTRO_FEATURES = "x11 opengl"
29
30# Remove the mesa-glu dependency in mesa-glu-dev, as mesa-glu is empty
31DEV_PKG_DEPENDENCY = ""
32