1SUMMARY = "Custom Matchbox session files"
2DESCRIPTION = "Very simple session manager for matchbox tools"
3HOMEPAGE = "http://www.matchbox-project.org/"
4BUGTRACKER = "http://bugzilla.yoctoproject.org/"
5
6LICENSE = "GPL-2.0-only"
7LIC_FILES_CHKSUM = "file://matchbox-session;endline=20;md5=180f1c169a15d059a56c30094f6fb5ea"
8
9SECTION = "x11"
10RCONFLICTS:${PN} = "matchbox-common"
11
12SRC_URI = "file://matchbox-session"
13
14S = "${WORKDIR}/sources"
15UNPACKDIR = "${S}"
16
17
18inherit update-alternatives
19
20ALTERNATIVE:${PN} = "x-session-manager"
21ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/matchbox-session"
22ALTERNATIVE_PRIORITY = "100"
23
24do_install() {
25	install -d ${D}/${bindir}
26	install -m 0755 ${S}/matchbox-session ${D}/${bindir}
27}
28