1eb8dc403SDave CobbleySUMMARY = "Custom Matchbox session files"
2*1d80a2eaSBrad BishopDESCRIPTION = "Very simple session manager for matchbox tools"
3eb8dc403SDave CobbleyHOMEPAGE = "http://www.matchbox-project.org/"
4eb8dc403SDave CobbleyBUGTRACKER = "http://bugzilla.yoctoproject.org/"
5eb8dc403SDave Cobbley
6eb8dc403SDave CobbleyLICENSE = "GPLv2"
7eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://matchbox-session;endline=20;md5=180f1c169a15d059a56c30094f6fb5ea"
8eb8dc403SDave Cobbley
9eb8dc403SDave CobbleySECTION = "x11"
10eb8dc403SDave CobbleyRCONFLICTS_${PN} = "matchbox-common"
11eb8dc403SDave Cobbley
12eb8dc403SDave CobbleySRC_URI = "file://matchbox-session"
13eb8dc403SDave CobbleyS = "${WORKDIR}"
14eb8dc403SDave Cobbley
15eb8dc403SDave CobbleyPR = "r4"
16eb8dc403SDave Cobbley
17eb8dc403SDave Cobbleyinherit update-alternatives
18eb8dc403SDave Cobbley
19eb8dc403SDave CobbleyALTERNATIVE_${PN} = "x-session-manager"
20eb8dc403SDave CobbleyALTERNATIVE_TARGET[x-session-manager] = "${bindir}/matchbox-session"
21eb8dc403SDave CobbleyALTERNATIVE_PRIORITY = "100"
22eb8dc403SDave Cobbley
23eb8dc403SDave Cobbleydo_install() {
24eb8dc403SDave Cobbley	install -d ${D}/${bindir}
25eb8dc403SDave Cobbley	install -m 0755 ${S}/matchbox-session ${D}/${bindir}
26eb8dc403SDave Cobbley}
27