1SUMMARY = "Demo application to showcase 3D graphics using kms and gbm"
2DESCRIPTION = "kmscube is a little demonstration program for how to drive bare metal graphics \
3without a compositor like X11, wayland or similar, using DRM/KMS (kernel mode \
4setting), GBM (graphics buffer manager) and EGL for rendering content using \
5OpenGL or OpenGL ES."
6HOMEPAGE = "https://cgit.freedesktop.org/mesa/kmscube/"
7LICENSE = "MIT"
8SECTION = "graphics"
9DEPENDS = "virtual/libgles3 virtual/libgles2 virtual/egl libdrm virtual/libgbm"
10
11LIC_FILES_CHKSUM = "file://kmscube.c;beginline=1;endline=23;md5=8b309d4ee67b7315ff7381270dd631fb"
12
13SRCREV = "345111481d654b38a72b5c3629151dc74f7a82bc"
14SRC_URI = "git://gitlab.freedesktop.org/mesa/kmscube;branch=master;protocol=https"
15UPSTREAM_CHECK_COMMITS = "1"
16
17S = "${WORKDIR}/git"
18
19inherit meson pkgconfig features_check
20
21REQUIRED_DISTRO_FEATURES = "opengl"
22
23PACKAGECONFIG ??= ""
24PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,gstreamer1.0 gstreamer1.0-plugins-base"
25
26CFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '-DEGL_NO_X11=1', d)}"
27
28