1SUMMARY = "Documentation generator for glib-based software"
2DESCRIPTION = "Gtk-doc is a set of scripts that extract specially formatted comments \
3               from glib-based software and produce a set of html documentation files from them"
4HOMEPAGE = "https://www.gtk.org/docs/"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8inherit gnomebase
9
10# Configure the scripts correctly (and build their dependencies) only if they are actually
11# going to be used; otheriwse we need only the m4/makefile includes from the gtk-doc tarball.
12PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "api-documentation", "working-scripts", "", d)}"
13
14# This will cause target gtk-doc to hardcode paths of native dependencies
15# into its scripts. This means that target gtk-doc package is broken;
16# hopefully no one minds because its scripts are not used for anything during build
17# and shouldn't be used on targets.
18PACKAGECONFIG[working-scripts] = ",,libxslt-native xmlto-native python3-six python3-pygments"
19PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,glib-2.0"
20
21SRC_URI[archive.sha256sum] = "cc1b709a20eb030a278a1f9842a362e00402b7f834ae1df4c1998a723152bf43"
22SRC_URI += "file://0001-Do-not-hardocode-paths-to-perl-python-in-scripts.patch \
23           file://0001-Do-not-error-out-if-xsltproc-is-not-found.patch \
24           file://conditionaltests.patch \
25           file://no-clobber.patch \
26           "
27SRC_URI_append_class-native = " file://pkg-config-native.patch"
28
29BBCLASSEXTEND = "native nativesdk"
30
31# Do not check for XML catalogs when building because that
32# information is not used for anything during build. Recipe
33# dependencies make sure we have all the right bits.
34do_configure_prepend() {
35        sed -i -e 's,^JH_CHECK_XML_CATALOG.*,,' ${S}/configure.ac
36}
37
38do_install_append () {
39    # configure values for python3 and pkg-config encoded in scripts
40    for fn in ${bindir}/gtkdoc-depscan \
41        ${bindir}/gtkdoc-mkhtml2 \
42        ${datadir}/gtk-doc/python/gtkdoc/config_data.py \
43        ${datadir}/gtk-doc/python/gtkdoc/config.py; do
44        sed -e 's,${RECIPE_SYSROOT_NATIVE}/usr/bin/pkg-config,${bindir}/pkg-config,' \
45            -e 's,${HOSTTOOLS_DIR}/python3,${bindir}/python3,' \
46            -i ${D}$fn
47    done
48}
49
50FILES_${PN} += "${datadir}/sgml"
51FILES_${PN}-dev += "${libdir}/cmake"
52FILES_${PN}-doc = ""
53
54SYSROOT_PREPROCESS_FUNCS_append_class-native = " gtkdoc_makefiles_sysroot_preprocess"
55gtkdoc_makefiles_sysroot_preprocess() {
56        # Patch the gtk-doc makefiles so that the qemu wrapper is used to run transient binaries
57        # instead of libtool wrapper or running them directly
58        sed -i \
59           -e "s|GTKDOC_RUN =.*|GTKDOC_RUN = \$(top_builddir)/gtkdoc-qemuwrapper|" \
60           ${SYSROOT_DESTDIR}${datadir}/gtk-doc/data/gtk-doc*make
61}
62