1SUMMARY = "GNOME configuration system"
2DESCRIPTION = "GConf is a system for storing application preferences. \
3It is intended for user preferences; not configuration of something like \
4Apache, or arbitrary data storage."
5SECTION = "x11/gnome"
6HOMEPAGE = "https://gitlab.gnome.org/Archive/gconf"
7LICENSE = "LGPL-2.0-or-later"
8LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
9
10DEPENDS = "glib-2.0 dbus dbus-glib libxml2 intltool-native"
11
12inherit gnomebase gtk-doc gettext gobject-introspection gio-module-cache
13
14SRC_URI = "${GNOME_MIRROR}/GConf/${@gnome_verdir("${PV}")}/GConf-${PV}.tar.xz;name=archive \
15           file://remove_plus_from_invalid_characters_list.patch \
16           file://unable-connect-dbus.patch \
17           file://create_config_directory.patch \
18           file://python3.patch \
19"
20
21SRC_URI[archive.md5sum] = "2b16996d0e4b112856ee5c59130e822c"
22SRC_URI[archive.sha256sum] = "1912b91803ab09a5eed34d364bf09fe3a2a9c96751fde03a4e0cfa51a04d784c"
23
24S = "${WORKDIR}/GConf-${PV}"
25
26EXTRA_OECONF = "--enable-shared --disable-static \
27                --disable-orbit --with-openldap=no --disable-gtk"
28
29PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)}"
30# We really don't want Polkit for native
31PACKAGECONFIG:class-native = ""
32
33PACKAGECONFIG[polkit] = "--enable-defaults-service,--disable-defaults-service,polkit"
34PACKAGECONFIG[debug] = "--enable-debug=yes, --enable-debug=minimum"
35
36do_install:append() {
37	# this directory need to be created to avoid an Error 256 at gdm launch
38	install -d ${D}${sysconfdir}/gconf/gconf.xml.system
39
40	# this stuff is unusable
41	rm -f ${D}${libdir}/GConf/*/*.*a
42	rm -f ${D}${libdir}/gio/*/*.*a
43}
44
45do_install:append:class-native() {
46	create_wrapper ${D}/${bindir}/gconftool-2 \
47		GCONF_BACKEND_DIR=${STAGING_LIBDIR_NATIVE}/GConf/2
48}
49
50FILES:${PN} += "${libdir}/GConf/* \
51                ${libdir}/gio/*/*.so \
52                ${datadir}/polkit* \
53                ${datadir}/dbus-1/services/*.service \
54                ${datadir}/dbus-1/system-services/*.service \
55               "
56RDEPENDS:${PN} = "python3-xml"
57
58FILES:${PN}-dev += "${datadir}/sgml/gconf/gconf-1.0.dtd"
59
60BBCLASSEXTEND = "native"
61