1SUMMARY = "Compressor/archiver for creating and modifying .zip files"
2HOMEPAGE = "http://www.info-zip.org"
3SECTION = "console/utils"
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=04d43c5d70b496c032308106e26ae17d"
7
8PR = "r2"
9
10S = "${WORKDIR}/zip30"
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/infozip/Zip%203.x%20%28latest%29/3.0/zip30.tar.gz \
13           file://fix-security-format.patch \
14           file://10-remove-build-date.patch \
15           file://zipnote-crashes-with-segfault.patch \
16           "
17UPSTREAM_VERSION_UNKNOWN = "1"
18
19SRC_URI[md5sum] = "7b74551e63f8ee6aab6fbc86676c0d37"
20SRC_URI[sha256sum] = "f0e8bb1f9b7eb0b01285495a2699df3a4b766784c1765a8f1aeedf63c0806369"
21
22# Disputed and also Debian doesn't consider a vulnerability
23CVE_CHECK_WHITELIST += "CVE-2018-13410"
24
25# Not for zip but for smart contract implementation for it
26CVE_CHECK_WHITELIST += "CVE-2018-13684"
27
28# zip.inc sets CFLAGS, but what Makefile actually uses is
29# CFLAGS_NOOPT.  It will also force -O3 optimization, overriding
30# whatever we set.
31EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
32		'CFLAGS=-I. -DUNIX ${CFLAGS}' \
33		'CFLAGS_NOOPT=-I. -DUNIX ${CFLAGS}' \
34		'INSTALL=install' 'INSTALL_D=install -d' \
35		'BINFLAGS=0755'"
36
37do_compile() {
38	oe_runmake -f unix/Makefile flags IZ_BZIP2=no_such_directory
39	sed -i 's#LFLAGS1=""#LFLAGS1="${LDFLAGS}"#' flags
40	oe_runmake -f unix/Makefile generic IZ_BZIP2=no_such_directory
41}
42
43do_install() {
44	oe_runmake -f unix/Makefile prefix=${D}${prefix} \
45		   BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \
46		   install
47}
48
49BBCLASSEXTEND = "native"
50
51# exclude version 2.3.2 which triggers a false positive
52UPSTREAM_CHECK_REGEX = "^zip(?P<pver>(?!232).+)\.tgz"
53