1SUMMARY = "Compressor/archiver for creating and modifying .zip files"
2HOMEPAGE = "http://www.info-zip.org"
3DESCRIPTION = "Info-ZIP's purpose is to provide free, portable, high-quality versions of the Zip and UnZip compressor-archiver utilities that are compatible with the DOS-based PKZIP by PKWARE, Inc."
4SECTION = "console/utils"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=04d43c5d70b496c032308106e26ae17d"
8
9PR = "r2"
10
11S = "${WORKDIR}/zip30"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/infozip/Zip%203.x%20%28latest%29/3.0/zip30.tar.gz \
14           file://fix-security-format.patch \
15           file://10-remove-build-date.patch \
16           file://zipnote-crashes-with-segfault.patch \
17           file://0001-configure-use-correct-CPP.patch \
18           file://0002-configure-support-PIC-code-build.patch \
19           file://0001-configure-Use-CFLAGS-and-LDFLAGS-when-doing-link-tes.patch \
20           file://0001-configure-Specify-correct-function-signatures-and-de.patch \
21           file://0002-unix.c-Do-not-redefine-DIR-as-FILE.patch \
22           file://0001-unix-configure-use-_Static_assert-to-do-correct-dete.patch \
23           "
24UPSTREAM_VERSION_UNKNOWN = "1"
25
26SRC_URI[md5sum] = "7b74551e63f8ee6aab6fbc86676c0d37"
27SRC_URI[sha256sum] = "f0e8bb1f9b7eb0b01285495a2699df3a4b766784c1765a8f1aeedf63c0806369"
28
29CVE_STATUS[CVE-2018-13410] = "disputed: Disputed and also Debian doesn't consider a vulnerability"
30CVE_STATUS[CVE-2018-13684] = "cpe-incorrect: Not for zip but for smart contract implementation for it"
31
32# zip.inc sets CFLAGS, but what Makefile actually uses is
33# CFLAGS_NOOPT.  It will also force -O3 optimization, overriding
34# whatever we set.
35EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
36		'CFLAGS=-I. -DUNIX ${CFLAGS}' \
37		'CFLAGS_NOOPT=-I. -DUNIX ${CFLAGS}' \
38		'INSTALL=install' 'INSTALL_D=install -d' \
39		'BINFLAGS=0755'"
40
41do_compile() {
42	oe_runmake -f unix/Makefile flags IZ_BZIP2=no_such_directory
43	sed -i 's#LFLAGS1=""#LFLAGS1="${LDFLAGS}"#' flags
44	oe_runmake -f unix/Makefile generic IZ_BZIP2=no_such_directory
45}
46
47do_install() {
48	oe_runmake -f unix/Makefile prefix=${D}${prefix} \
49		   BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \
50		   install
51}
52
53BBCLASSEXTEND = "native"
54
55# exclude version 2.3.2 which triggers a false positive
56UPSTREAM_CHECK_REGEX = "^zip(?P<pver>(?!232).+)\.tgz"
57