1SUMMARY = "Software watchdog"
2DESCRIPTION = "Watchdog is a daemon that checks if your system is still \
3working. If programs in user space are not longer executed it will reboot \
4the system."
5HOMEPAGE = "http://watchdog.sourceforge.net/"
6BUGTRACKER = "http://sourceforge.net/tracker/?group_id=172030&atid=860194"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
10
11SRC_URI = " \
12    file://watchdog.default \
13    file://watchdog.conf \
14"
15
16S = "${WORKDIR}/sources"
17UNPACKDIR = "${S}"
18
19# The default value is 60 seconds when null.
20WATCHDOG_TIMEOUT ??= ""
21
22do_install() {
23    install -Dm 0644 ${UNPACKDIR}/watchdog.default ${D}${sysconfdir}/default/watchdog
24    install -Dm 0644 ${UNPACKDIR}/watchdog.conf ${D}${sysconfdir}/watchdog.conf
25
26    if [ -n "${WATCHDOG_TIMEOUT}" ]; then
27        echo "watchdog-timeout = ${WATCHDOG_TIMEOUT}" >> ${D}/etc/watchdog.conf
28    fi
29}
30
31