1eb8dc403SDave CobbleySUMMARY = "Software watchdog"
2eb8dc403SDave CobbleyDESCRIPTION = "Watchdog is a daemon that checks if your system is still \
3eb8dc403SDave Cobbleyworking. If programs in user space are not longer executed it will reboot \
4eb8dc403SDave Cobbleythe system."
5eb8dc403SDave CobbleyHOMEPAGE = "http://watchdog.sourceforge.net/"
6eb8dc403SDave CobbleyBUGTRACKER = "http://sourceforge.net/tracker/?group_id=172030&atid=860194"
7eb8dc403SDave Cobbley
87e0e3c0cSAndrew GeisslerLICENSE = "MIT"
9eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
10eb8dc403SDave Cobbley
11eb8dc403SDave CobbleySRC_URI = " \
12eb8dc403SDave Cobbley    file://watchdog.default \
13eb8dc403SDave Cobbley    file://watchdog.conf \
14eb8dc403SDave Cobbley"
15eb8dc403SDave Cobbley
16*78b72798SAndrew Geissler# The default value is 60 seconds when null.
17*78b72798SAndrew GeisslerWATCHDOG_TIMEOUT ??= ""
18*78b72798SAndrew Geissler
19eb8dc403SDave Cobbleydo_install() {
20eb8dc403SDave Cobbley    install -Dm 0644 ${WORKDIR}/watchdog.default ${D}${sysconfdir}/default/watchdog
21eb8dc403SDave Cobbley    install -Dm 0644 ${WORKDIR}/watchdog.conf ${D}${sysconfdir}/watchdog.conf
22*78b72798SAndrew Geissler
23*78b72798SAndrew Geissler    if [ -n "${WATCHDOG_TIMEOUT}" ]; then
24*78b72798SAndrew Geissler        echo "watchdog-timeout = ${WATCHDOG_TIMEOUT}" >> ${D}/etc/watchdog.conf
25*78b72798SAndrew Geissler    fi
26eb8dc403SDave Cobbley}
27eb8dc403SDave Cobbley
28