1SUMMARY = "System load testing utility"
2DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
3imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
4HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme"
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master \
9           "
10SRCREV = "27f1171ff0718e67eac0730df34cbfd97aca587b"
11S = "${WORKDIR}/git"
12
13DEPENDS = "coreutils-native libbsd"
14
15PROVIDES = "stress"
16RPROVIDES:${PN} = "stress"
17RREPLACES:${PN} = "stress"
18RCONFLICTS:${PN} = "stress"
19
20inherit bash-completion
21
22EXTRA_OEMAKE = "VERBOSE=1"
23
24do_configure() {
25    mkdir -p configs
26    touch configs/HAVE_APPARMOR
27    oe_runmake makeconfig
28}
29
30do_install() {
31    oe_runmake DESTDIR=${D} BINDIR=${bindir} install
32    ln -s stress-ng ${D}${bindir}/stress
33}
34
35# upstream issue: https://github.com/ColinIanKing/stress-ng/issues/315
36DEBUG_BUILD = "0"
37