1SUMMARY = "Shadow utils requirements for useradd.bbclass"
2HOMEPAGE = "http://github.com/shadow-maint/shadow"
3BUGTRACKER = "http://github.com/shadow-maint/shadow/issues"
4SECTION = "base utils"
5LICENSE = "BSD-3-Clause | Artistic-1.0"
6LIC_FILES_CHKSUM = "file://login.defs_shadow-sysroot;endline=1;md5=ceddfb61608e4db87012499555184aed"
7
8DEPENDS = "base-passwd"
9
10
11# The sole purpose of this recipe is to provide the /etc/login.defs
12# file for the target sysroot - needed so the shadow-native utilities
13# can add custom users/groups for recipes that use inherit useradd.
14SRC_URI = "file://login.defs_shadow-sysroot"
15
16S = "${WORKDIR}"
17
18do_install() {
19	install -d ${D}${sysconfdir}
20	install -p -m 644 ${S}/login.defs_shadow-sysroot ${D}${sysconfdir}/login.defs
21}
22
23SYSROOT_DIRS += "${sysconfdir}"
24
25# don't create any packages
26# otherwise: dbus-dev depends on shadow-sysroot-dev which depends on shadow-sysroot
27# and this has another copy of /etc/login.defs already provided by shadow
28PACKAGES = ""
29
30inherit nopackages
31