1# Copyright (C) 2018 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "rpcsvc protocol definitions from glibc"
5
6DESCRIPTION = "This package contains rpcsvc proto.x files from glibc, which are\
7missing in libtirpc. Additional it contains rpcgen, which is needed\
8to create header files and sources from protocol files.\
9This package is only needed, if glibc is installed without the\
10deprecated sunrpc functionality and libtirpc should replace it."
11
12HOMEPAGE = "https://github.com/thkukuk/rpcsvc-proto"
13LICENSE = "BSD-3-Clause"
14LIC_FILES_CHKSUM = "file://COPYING;md5=0daaf958d5531ab86169ec6e275e1517"
15SECTION = "libs"
16DEPENDS += "rpcsvc-proto-native"
17
18PV = "1.4.3"
19
20SRCREV = "71e0a12c04d130a78674ac6309eefffa6ecee612"
21
22SRC_URI = "git://github.com/thkukuk/${BPN};branch=master;protocol=https \
23           file://0001-Use-cross-compiled-rpcgen.patch \
24           file://0001-Use-AC_SYS_LARGEFILE-macro-to-control-largefile-supp.patch \
25           "
26
27S = "${WORKDIR}/git"
28
29inherit autotools gettext
30
31EXTRA_OEMAKE:class-native = " -C rpcgen"
32
33do_configure:prepend() {
34	touch ${S}/ABOUT-NLS
35}
36
37do_install:append() {
38	# They come from quota recipe
39	rm -rf ${D}${includedir}/rpcsvc/rquota.[hx]
40}
41
42BBCLASSEXTEND += "native nativesdk"
43