1SUMMARY = "Universal Addresses to RPC Program Number Mapper"
2DESCRIPTION = "The rpcbind utility is a server that converts RPC \
3               program numbers into universal addresses."
4SECTION = "console/network"
5HOMEPAGE = "http://sourceforge.net/projects/rpcbind/"
6BUGTRACKER = "http://sourceforge.net/tracker/?group_id=201237&atid=976751"
7DEPENDS = "libtirpc quota"
8
9LICENSE = "BSD-3-Clause"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b46486e4c4a416602693a711bb5bfa39 \
11                    file://src/rpcinfo.c;beginline=1;endline=27;md5=f8a8cd2cb25ac5aa16767364fb0e3c24"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/rpcbind/rpcbind-${PV}.tar.bz2 \
14           file://init.d \
15           file://rpcbind.conf \
16           file://rpcbind_add_option_to_fix_port_number.patch \
17           file://0001-systemd-use-EnvironmentFile.patch \
18          "
19SRC_URI[sha256sum] = "5613746489cae5ae23a443bb85c05a11741a5f12c8f55d2bb5e83b9defeee8de"
20
21inherit autotools update-rc.d systemd pkgconfig update-alternatives
22
23PACKAGECONFIG ??= "tcp-wrappers"
24PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
25
26INITSCRIPT_NAME = "rpcbind"
27INITSCRIPT_PARAMS = "start 12 2 3 4 5 . stop 60 0 1 6 ."
28
29SYSTEMD_SERVICE:${PN} = "rpcbind.service rpcbind.socket"
30
31inherit useradd
32
33USERADD_PACKAGES = "${PN}"
34USERADD_PARAM:${PN} = "--system --no-create-home --home-dir / \
35                       --shell /bin/false --user-group rpc"
36
37PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
38PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}/, \
39                          --without-systemdsystemunitdir, \
40                          systemd \
41"
42
43EXTRA_OECONF += " --enable-warmstarts --with-rpcuser=rpc --with-statedir=${runtimedir}/rpcbind"
44
45do_install:append () {
46	install -d ${D}${sysconfdir}/init.d
47	sed -e 's,/etc/,${sysconfdir}/,g' \
48		-e 's,/sbin/,${sbindir}/,g' \
49		${WORKDIR}/init.d > ${D}${sysconfdir}/init.d/rpcbind
50	chmod 0755 ${D}${sysconfdir}/init.d/rpcbind
51	install -m 0644 ${WORKDIR}/rpcbind.conf ${D}${sysconfdir}/rpcbind.conf
52}
53
54ALTERNATIVE:${PN} = "rpcinfo"
55ALTERNATIVE_LINK_NAME[rpcinfo] = "${bindir}/rpcinfo"
56