1SUMMARY = "Perl module for using and building Perl SAX2 XML processors"
2HOMEPAGE = "http://search.cpan.org/dist/XML-SAX/"
3DESCRIPTION = "XML::SAX consists of several framework classes for using and \
4building Perl SAX2 XML parsers, filters, and drivers.  It is designed \
5around the need to be able to "plug in" different SAX parsers to an \
6application without requiring programmer intervention.  Those of you \
7familiar with the DBI will be right at home.  Some of the designs \
8come from the Java JAXP specification (SAX part), only without the \
9javaness."
10
11SECTION = "libs"
12LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
13DEPENDS += "libxml-namespacesupport-perl-native"
14RDEPENDS:${PN} += "libxml-namespacesupport-perl libxml-sax-base-perl perl-module-file-temp"
15
16LIC_FILES_CHKSUM = "file://LICENSE;md5=65c4cd8f39c24c7135ed70dacbcb09e3"
17
18SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GR/GRANTM/XML-SAX-${PV}.tar.gz"
19
20SRC_URI[md5sum] = "b62e3754523695c7f5bbcafa3676a38d"
21SRC_URI[sha256sum] = "4506c387043aa6a77b455f00f57409f3720aa7e553495ab2535263b4ed1ea12a"
22
23S = "${WORKDIR}/XML-SAX-${PV}"
24
25inherit cpan ptest-perl
26
27do_install_ptest() {
28	cp -r ${B}/testfiles ${D}${PTEST_PATH}
29	chown -R root:root ${D}${PTEST_PATH}/testfiles
30}
31
32RDEPENDS:${PN} += "perl-module-encode perl-module-perlio perl-module-encode-encoding"
33
34RDEPENDS:${PN}-ptest += " \
35    perl-module-base  \
36    perl-module-encode-byte \
37    perl-module-encode-unicode \
38    perl-module-fatal \
39    perl-module-test \
40"
41
42BBCLASSEXTEND = "native nativesdk"
43