1SUMMARY = "PBZIP2 is a parallel implementation of bzip2"
2DESCRIPTION = "PBZIP2 is a parallel implementation of the bzip2 block-sorting \
3file compressor that uses pthreads and achieves near-linear speedup on SMP \
4machines. The output of this version is fully compatible with bzip2 v1.0.2 or \
5newer (ie: anything compressed with pbzip2 can be decompressed with bzip2)."
6HOMEPAGE = "http://compression.ca/pbzip2/"
7SECTION = "console/utils"
8LICENSE = "bzip2-1.0.6"
9LIC_FILES_CHKSUM = "file://COPYING;md5=398b8832c6f840cfebd20ab2be6a3743"
10
11DEPENDS = "bzip2"
12DEPENDS_append_class-native = " bzip2-replacement-native"
13
14SRC_URI = "https://launchpad.net/${BPN}/1.1/${PV}/+download/${BP}.tar.gz \
15           file://0001-pbzip2-Fix-invalid-suffix-on-literal-C-11-warning.patch \
16           "
17
18SRC_URI[md5sum] = "4cb87da2dba05540afce162f34b3a9a6"
19SRC_URI[sha256sum] = "8fd13eaaa266f7ee91f85c1ea97c86d9c9cc985969db9059cdebcb1e1b7bdbe6"
20
21UPSTREAM_CHECK_URI = "https://launchpad.net/pbzip2/+milestones"
22UPSTREAM_CHECK_REGEX = "pbzip2 (?P<pver>\d+(\.\d+)+)"
23
24EXTRA_OEMAKE = "CXX='${CXX} ${CXXFLAGS}' LDFLAGS='${LDFLAGS}'"
25
26do_install() {
27    install -d ${D}${bindir}
28    install -m 0755 pbzip2 ${D}${bindir}/
29}
30
31BBCLASSEXTEND = "native"
32