1*eb8dc403SDave CobbleySUMMARY = "PBZIP2 is a parallel implementation of bzip2"
2*eb8dc403SDave CobbleyDESCRIPTION = "PBZIP2 is a parallel implementation of the bzip2 block-sorting \
3*eb8dc403SDave Cobbleyfile compressor that uses pthreads and achieves near-linear speedup on SMP \
4*eb8dc403SDave Cobbleymachines. The output of this version is fully compatible with bzip2 v1.0.2 or \
5*eb8dc403SDave Cobbleynewer (ie: anything compressed with pbzip2 can be decompressed with bzip2)."
6*eb8dc403SDave CobbleyHOMEPAGE = "http://compression.ca/pbzip2/"
7*eb8dc403SDave CobbleySECTION = "console/utils"
8*eb8dc403SDave CobbleyLICENSE = "BSD"
9*eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://COPYING;md5=398b8832c6f840cfebd20ab2be6a3743"
10*eb8dc403SDave Cobbley
11*eb8dc403SDave CobbleyDEPENDS = "bzip2"
12*eb8dc403SDave CobbleyDEPENDS_append_class-native = " bzip2-replacement-native"
13*eb8dc403SDave Cobbley
14*eb8dc403SDave CobbleySRC_URI = "https://launchpad.net/${BPN}/1.1/${PV}/+download/${BP}.tar.gz"
15*eb8dc403SDave Cobbley
16*eb8dc403SDave CobbleySRC_URI[md5sum] = "4cb87da2dba05540afce162f34b3a9a6"
17*eb8dc403SDave CobbleySRC_URI[sha256sum] = "8fd13eaaa266f7ee91f85c1ea97c86d9c9cc985969db9059cdebcb1e1b7bdbe6"
18*eb8dc403SDave Cobbley
19*eb8dc403SDave CobbleyUPSTREAM_CHECK_URI = "http://compression.ca/pbzip2/"
20*eb8dc403SDave Cobbley
21*eb8dc403SDave CobbleyEXTRA_OEMAKE = "CXX='${CXX} ${CXXFLAGS}' LDFLAGS='${LDFLAGS}'"
22*eb8dc403SDave Cobbley
23*eb8dc403SDave Cobbleydo_install() {
24*eb8dc403SDave Cobbley    install -d ${D}${bindir}
25*eb8dc403SDave Cobbley    install -m 0755 pbzip2 ${D}${bindir}/
26*eb8dc403SDave Cobbley}
27*eb8dc403SDave Cobbley
28*eb8dc403SDave CobbleyBBCLASSEXTEND = "native"
29