1eb8dc403SDave CobbleySUMMARY = "PBZIP2 is a parallel implementation of bzip2"
2eb8dc403SDave CobbleyDESCRIPTION = "PBZIP2 is a parallel implementation of the bzip2 block-sorting \
3eb8dc403SDave Cobbleyfile compressor that uses pthreads and achieves near-linear speedup on SMP \
4eb8dc403SDave Cobbleymachines. The output of this version is fully compatible with bzip2 v1.0.2 or \
5eb8dc403SDave Cobbleynewer (ie: anything compressed with pbzip2 can be decompressed with bzip2)."
6eb8dc403SDave CobbleyHOMEPAGE = "http://compression.ca/pbzip2/"
7eb8dc403SDave CobbleySECTION = "console/utils"
8eb8dc403SDave CobbleyLICENSE = "BSD"
9eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://COPYING;md5=398b8832c6f840cfebd20ab2be6a3743"
10eb8dc403SDave Cobbley
11eb8dc403SDave CobbleyDEPENDS = "bzip2"
12eb8dc403SDave CobbleyDEPENDS_append_class-native = " bzip2-replacement-native"
13eb8dc403SDave Cobbley
14*1a4b7ee2SBrad BishopSRC_URI = "https://launchpad.net/${BPN}/1.1/${PV}/+download/${BP}.tar.gz \
15*1a4b7ee2SBrad Bishop           file://0001-pbzip2-Fix-invalid-suffix-on-literal-C-11-warning.patch \
16*1a4b7ee2SBrad Bishop           "
17eb8dc403SDave Cobbley
18eb8dc403SDave CobbleySRC_URI[md5sum] = "4cb87da2dba05540afce162f34b3a9a6"
19eb8dc403SDave CobbleySRC_URI[sha256sum] = "8fd13eaaa266f7ee91f85c1ea97c86d9c9cc985969db9059cdebcb1e1b7bdbe6"
20eb8dc403SDave Cobbley
21*1a4b7ee2SBrad BishopUPSTREAM_CHECK_URI = "https://launchpad.net/pbzip2/+milestones"
22*1a4b7ee2SBrad BishopUPSTREAM_CHECK_REGEX = "pbzip2 (?P<pver>\d+(\.\d+)+)"
23eb8dc403SDave Cobbley
24eb8dc403SDave CobbleyEXTRA_OEMAKE = "CXX='${CXX} ${CXXFLAGS}' LDFLAGS='${LDFLAGS}'"
25eb8dc403SDave Cobbley
26eb8dc403SDave Cobbleydo_install() {
27eb8dc403SDave Cobbley    install -d ${D}${bindir}
28eb8dc403SDave Cobbley    install -m 0755 pbzip2 ${D}${bindir}/
29eb8dc403SDave Cobbley}
30eb8dc403SDave Cobbley
31eb8dc403SDave CobbleyBBCLASSEXTEND = "native"
32