1#
2# Copyright (C) 2010 Intel Corporation
3#
4
5SUMMARY = "Standard full-featured Linux system"
6DESCRIPTION = "Package group bringing in packages needed for a more traditional full-featured Linux system"
7
8inherit packagegroup
9
10PACKAGES = "\
11    packagegroup-core-full-cmdline \
12    packagegroup-core-full-cmdline-utils \
13    packagegroup-core-full-cmdline-extended \
14    packagegroup-core-full-cmdline-dev-utils \
15    packagegroup-core-full-cmdline-multiuser \
16    packagegroup-core-full-cmdline-initscripts \
17    packagegroup-core-full-cmdline-sys-services \
18    "
19
20RDEPENDS:packagegroup-core-full-cmdline = "\
21    packagegroup-core-full-cmdline-utils \
22    packagegroup-core-full-cmdline-extended \
23    packagegroup-core-full-cmdline-dev-utils \
24    packagegroup-core-full-cmdline-multiuser \
25    packagegroup-core-full-cmdline-initscripts \
26    packagegroup-core-full-cmdline-sys-services \
27    "
28
29RDEPENDS:packagegroup-core-full-cmdline-utils = "\
30    bash \
31    acl \
32    attr \
33    bc \
34    coreutils \
35    cpio \
36    e2fsprogs \
37    ed \
38    file \
39    findutils \
40    gawk \
41    grep \
42    less \
43    makedevs \
44    mc \
45    mc-shell \
46    mc-helpers \
47    mc-helpers-perl \
48    ncurses \
49    net-tools \
50    procps \
51    psmisc \
52    sed \
53    tar \
54    time \
55    util-linux \
56    "
57
58RDEPENDS:packagegroup-core-full-cmdline-extended = "\
59    iproute2 \
60    iputils \
61    iptables \
62    module-init-tools \
63    openssl \
64    "
65
66RDEPENDS:packagegroup-core-full-cmdline-dev-utils = "\
67    diffutils \
68    m4 \
69    make \
70    patch \
71    "
72
73VIRTUAL-RUNTIME_syslog ?= "sysklogd"
74RDEPENDS:packagegroup-core-full-cmdline-initscripts = "\
75    ${VIRTUAL-RUNTIME_initscripts} \
76    ${VIRTUAL-RUNTIME_init_manager} \
77    ethtool \
78    ${VIRTUAL-RUNTIME_login_manager} \
79    ${VIRTUAL-RUNTIME_syslog} \
80    "
81
82RDEPENDS:packagegroup-core-full-cmdline-multiuser = "\
83    bzip2 \
84    cracklib \
85    gzip \
86    shadow \
87    sudo \
88    "
89
90RDEPENDS:packagegroup-core-full-cmdline-sys-services = "\
91    at \
92    cronie \
93    logrotate \
94    ${@bb.utils.contains('DISTRO_FEATURES', 'nfs', 'nfs-utils rpcbind', '', d)} \
95    "
96