1SUMMARY = "An implementation of the standard Unix documentation system accessed using the man command"
2HOMEPAGE = "http://man-db.nongnu.org/"
3DESCRIPTION = "man-db is an implementation of the standard Unix documentation system accessed using the man command. It uses a Berkeley DB database in place of the traditional flat-text whatis databases."
4LICENSE = "LGPL-2.1-or-later & GPL-2.0-or-later & GPL-3.0-or-later"
5LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464 \
6                    file://docs/COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7                    file://docs/COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8                   "
9
10SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/man-db/man-db-${PV}.tar.xz \
11           file://99_mandb \
12          "
13SRC_URI[sha256sum] = "82f0739f4f61aab5eb937d234de3b014e777b5538a28cbd31433c45ae09aefb9"
14
15DEPENDS = "libpipeline gdbm groff-native base-passwd"
16RDEPENDS:${PN} += "base-passwd"
17PACKAGE_WRITE_DEPS += "base-passwd"
18
19# | /usr/src/debug/man-db/2.8.0-r0/man-db-2.8.0/src/whatis.c:939: undefined reference to `_nl_msg_cat_cntr'
20USE_NLS:libc-musl = "no"
21
22inherit gettext pkgconfig autotools systemd
23
24EXTRA_OECONF = "--with-pager=less --with-systemdsystemunitdir=${systemd_system_unitdir}"
25EXTRA_AUTORECONF += "-I ${S}/gl/m4"
26
27PACKAGECONFIG[bzip2] = "--with-bzip2=bzip2,ac_cv_prog_have_bzip2='',bzip2"
28PACKAGECONFIG[gzip] = "--with-gzip=gzip,ac_cv_prog_have_gzip='',gzip"
29PACKAGECONFIG[lzip] = "--with-lzip=lzip,ac_cv_prog_have_lzip='',lzip"
30PACKAGECONFIG[lzma] = "--with-lzma=lzma,ac_cv_prog_have_lzma='',xz"
31PACKAGECONFIG[zstd] = "--with-zstd=zstd,ac_cv_prog_have_zstd='',zstd"
32PACKAGECONFIG[xz] = "--with-xz=xz,ac_cv_prog_have_xz='',xz"
33
34do_install() {
35	autotools_do_install
36
37	if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
38	        install -d ${D}/etc/default/volatiles
39		install -m 0644 ${UNPACKDIR}/99_mandb ${D}/etc/default/volatiles
40	fi
41}
42
43do_install:append:libc-musl() {
44        rm -f ${D}${libdir}/charset.alias
45}
46
47FILES:${PN} += "${prefix}/lib/tmpfiles.d"
48
49FILES:${PN}-dev += "${libdir}/man-db/libman.so ${libdir}/${BPN}/libmandb.so"
50
51RDEPENDS:${PN} += "groff"
52RRECOMMENDS:${PN} += "less"
53# iconv from glibc-utils can be used to transform encoding
54RRECOMMENDS:${PN}:append:libc-glibc = " glibc-utils"
55RPROVIDES:${PN} += "man"
56
57def compress_pkg(d):
58    if bb.utils.contains("INHERIT", "compress_doc", True, False, d):
59         compress = d.getVar("DOC_COMPRESS")
60         if compress == "gz":
61             return "gzip"
62         elif compress == "bz2":
63             return "bzip2"
64         elif compress == "xz":
65             return "xz"
66    return ""
67
68RDEPENDS:${PN} += "${@compress_pkg(d)}"
69
70SYSTEMD_SERVICE:${PN} = "man-db.timer man-db.service"
71SYSTEMD_AUTO_ENABLE ?= "disable"
72