1# Copyright (C) 2018 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "NSS module for glibc, to provide NIS support for glibc"
5
6DESCRIPTION = "This package contains the NSS NIS plugin for glibc.\
7This code was formerly part of glibc, but is now standalone to\
8be able to link against TI-RPC for IPv6 support."
9
10HOMEPAGE = "https://github.com/thkukuk/libnss_nis"
11LICENSE = "LGPL-2.1"
12LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
13SECTION = "libs"
14DEPENDS += "libtirpc libnsl2"
15
16PV = "3.1+git${SRCPV}"
17
18SRCREV = "062f31999b35393abf7595cb89dfc9590d5a42ad"
19
20SRC_URI = "git://github.com/thkukuk/libnss_nis;branch=master;protocol=https \
21          "
22
23S = "${WORKDIR}/git"
24
25inherit autotools pkgconfig
26
27BBCLASSEXTEND += "native nativesdk"
28#
29# We will skip parsing this packagegeoup for non-glibc systems
30#
31COMPATIBLE_HOST:libc-musl = 'null'
32