1DESCRIPTION = "A test controller image to be deployed on a target useful for testing other images using the OEQA runtime tests"
2
3IMAGE_FEATURES += "ssh-server-openssh package-management"
4
5inherit core-image
6
7# the deploy code requires bash and
8# normal linux utilities not busybox ones
9IMAGE_INSTALL += "\
10    bash coreutils util-linux tar gzip bzip2 kmod \
11    python3-modules python3-misc \
12    e2fsprogs e2fsprogs-mke2fs parted \
13    "
14# we need a particular initramfs for live images
15# that pulls custom install scripts which take
16# care of partitioning for us
17INITRD_IMAGE = "core-image-testcontroller-initramfs"
18
19