1DESCRIPTION = "A development image that builds the kernel and packages that are \
2sensitive to kernel updates and version changes"
3
4# Could also be core-image-basic, but we'll keep this small for now
5require recipes-core/images/core-image-minimal.bb
6
7KERNEL_DEV_UTILS ?= "dropbear connman"
8KERNEL_DEV_TOOLS ?= "packagegroup-core-tools-profile packagegroup-core-buildessential kernel-devsrc"
9KERNEL_DEV_MODULE ?= "kernel-modules"
10
11CORE_IMAGE_EXTRA_INSTALL += "${KERNEL_DEV_MODULE} \
12                             ${KERNEL_DEV_UTILS} \
13                             ${KERNEL_DEV_TOOLS} \
14                             systemtap \
15                            "
16
17# We need extra space for things like kernel builds, etc.
18IMAGE_ROOTFS_EXTRA_SPACE:append = " + 3000000"
19
20# Let's define our own subset to test, we can later add a on-target kernel build even!
21DEFAULT_TEST_SUITES = "ping ssh df connman syslog scp date parselogs"
22
23IMAGE_FEATURES += "tools-profile"
24