1DESCRIPTION = "GNU gperf is a perfect hash function generator"
2HOMEPAGE = "http://www.gnu.org/software/gperf"
3SUMMARY  = "Generate a perfect hash function from a set of keywords"
4LICENSE  = "GPLv3+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
6                    file://src/main.cc;beginline=8;endline=19;md5=dec8f611845d047387ed56b5b85fa99b"
7
8SRC_URI  = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz"
9SRC_URI[md5sum] = "9e251c0a618ad0824b51117d5d9db87e"
10SRC_URI[sha256sum] = "588546b945bba4b70b6a3a616e80b4ab466e3f33024a352fc2198112cdbb3ae2"
11
12inherit autotools
13
14# The nested configures don't find the parent aclocal.m4 out of the box, so tell
15# it where to look explicitly (mirroring the behaviour of upstream's Makefile.devel).
16EXTRA_AUTORECONF += " -I ${S} --exclude=aclocal"
17
18BBCLASSEXTEND = "native"
19