1SUMMARY = "This is a simple example recipe that cross-compiles a Go program."
2SECTION = "examples"
3HOMEPAGE = "https://golang.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
7
8SRC_URI = "git://go.googlesource.com/example;branch=master;protocol=https"
9SRCREV = "2e68773dfca072cb81f219fc3b97ad34fe9d9f94"
10UPSTREAM_CHECK_COMMITS = "1"
11
12GO_IMPORT = "golang.org/x/example"
13GO_INSTALL = "${GO_IMPORT}/hello"
14
15export GO111MODULE="off"
16
17inherit go
18
19# This is just to make clear where this example is
20do_install:append() {
21    mv ${D}${bindir}/hello ${D}${bindir}/${BPN}
22}
23