1LICENSE = "GPL-3.0-or-later"
2LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
3
4require diffutils.inc
5
6SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.xz \
7           file://run-ptest \
8           file://0001-Skip-strip-trailing-cr-test-case.patch \
9           "
10
11SRC_URI[sha256sum] = "90e5e93cc724e4ebe12ede80df1634063c7a855692685919bfe60b556c9bd09e"
12
13EXTRA_OECONF += "ac_cv_path_PR_PROGRAM=${bindir}/pr --without-libsigsegv-prefix"
14
15# latest gnulib is no longer able to handle this - I dare not try to fix that maze of abstractions and generators
16CFLAGS:mingw32 = " -DSA_RESTART=0"
17
18# Fix "Argument list too long" error when len(TMPDIR) = 410
19acpaths = "-I ./m4"
20
21EXTRA_OEMAKE:append:mingw32 = " LIBS='-lbcrypt'"
22inherit ptest
23
24RDEPENDS:${PN}-ptest += "make perl"
25
26do_install_ptest() {
27	t=${D}${PTEST_PATH}
28	install -D ${S}/build-aux/test-driver $t/build-aux/test-driver
29	cp -r ${S}/tests $t/
30	install ${B}/tests/Makefile $t/tests/
31	sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
32	    -e 's|${DEBUG_PREFIX_MAP}||g' \
33	    -e 's:${HOSTTOOLS_DIR}/::g' \
34	    -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
35	    -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
36	    -e 's|^Makefile:|_Makefile:|' \
37	    -e 's|bash|sh|' \
38	    -e 's|^top_srcdir = \(.*\)|top_srcdir = ..\/|' \
39	    -e 's|^srcdir = \(.*\)|srcdir = .|' \
40	    -e 's|"`$(built_programs)`"|diff|' \
41	    -e 's|gawk|awk|g' \
42	    -i $t/tests/Makefile
43}
44