1SUMMARY = "Very high-quality data compression program"
2DESCRIPTION = "bzip2 compresses files using the Burrows-Wheeler block-sorting text compression algorithm, and \
3Huffman coding. Compression is generally considerably better than that achieved by more conventional \
4LZ77/LZ78-based compressors, and approaches the performance of the PPM family of statistical compressors."
5HOMEPAGE = "https://sourceware.org/bzip2/"
6SECTION = "console/utils"
7LICENSE = "bzip2-1.0.6 & GPL-3.0-or-later & Apache-2.0 & MS-PL & BSD-3-Clause & Zlib"
8LICENSE:${PN} = "bzip2-1.0.6"
9LICENSE:${PN}-dev = "bzip2-1.0.6"
10LICENSE:${PN}-dbg = "bzip2-1.0.6"
11LICENSE:${PN}-doc = "bzip2-1.0.6"
12LICENSE:${PN}-src = "bzip2-1.0.6"
13LICENSE:libbz2 = "bzip2-1.0.6"
14LICENSE:${PN}-ptest = "bzip2-1.0.6 & GPL-3.0-or-later & Apache-2.0 & MS-PL & BSD-3-Clause & Zlib"
15
16LIC_FILES_CHKSUM = "file://LICENSE;beginline=4;endline=37;md5=600af43c50f1fcb82e32f19b32df4664 \
17                    file://${WORKDIR}/git/commons-compress/LICENSE.txt;md5=86d3f3a95c324c9479bd8986968f4327 \
18                    file://${WORKDIR}/git/dotnetzip/License.txt;md5=9cb56871eed4e748c3bc7e8ff352a54f \
19                    file://${WORKDIR}/git/dotnetzip/License.zlib.txt;md5=cc421ccd22eeb2e5db6b79e6de0a029f \
20                    file://${WORKDIR}/git/go/LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707 \
21                    file://${WORKDIR}/git/lbzip2/COPYING;md5=d32239bcb673463ab874e80d47fae504 \
22"
23
24SRC_URI = "https://sourceware.org/pub/${BPN}/${BPN}-${PV}.tar.gz \
25           git://sourceware.org/git/bzip2-tests.git;name=bzip2-tests;branch=master \
26           file://configure.ac;subdir=${BP} \
27           file://Makefile.am;subdir=${BP} \
28           file://run-ptest \
29           "
30SRC_URI[md5sum] = "67e051268d0c475ea773822f7500d0e5"
31SRC_URI[sha256sum] = "ab5a03176ee106d3f0fa90e381da478ddae405918153cca248e682cd0c4a2269"
32
33SRCREV_bzip2-tests = "f9061c030a25de5b6829e1abf373057309c734c0"
34
35UPSTREAM_CHECK_URI = "https://www.sourceware.org/pub/bzip2/"
36
37PACKAGES =+ "libbz2"
38
39CFLAGS:append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
40
41inherit autotools update-alternatives ptest relative_symlinks
42
43ALTERNATIVE_PRIORITY = "100"
44ALTERNATIVE:${PN} = "bunzip2 bzcat bzip2"
45
46#install binaries to bzip2-native under sysroot for replacement-native
47EXTRA_OECONF:append:class-native = " --bindir=${STAGING_BINDIR_NATIVE}/${PN}"
48
49do_configure:prepend () {
50    sed -i -e "s|%BZIP2_VERSION%|${PV}|" ${S}/configure.ac
51}
52
53do_install_ptest () {
54	install -d ${D}${PTEST_PATH}/bzip2-tests
55	cp -r ${WORKDIR}/git/commons-compress ${D}${PTEST_PATH}/bzip2-tests/commons-compress
56	cp -r ${WORKDIR}/git/dotnetzip ${D}${PTEST_PATH}/bzip2-tests/dotnetzip
57	cp -r ${WORKDIR}/git/go ${D}${PTEST_PATH}/bzip2-tests/go
58	cp -r ${WORKDIR}/git/lbzip2 ${D}${PTEST_PATH}/bzip2-tests/lbzip2
59	cp -r ${WORKDIR}/git/pyflate ${D}${PTEST_PATH}/bzip2-tests/pyflate
60	cp ${WORKDIR}/git/README ${D}${PTEST_PATH}/bzip2-tests/
61	cp ${WORKDIR}/git/run-tests.sh ${D}${PTEST_PATH}/bzip2-tests/
62	sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile
63}
64
65FILES:libbz2 = "${libdir}/lib*${SOLIBS}"
66
67RDEPENDS:${PN}-ptest += "make bash"
68
69PROVIDES:append:class-native = " bzip2-replacement-native"
70BBCLASSEXTEND = "native nativesdk"
71