1SUMMARY = "Selectively remove #ifdef statements from sources"
2SECTION = "devel"
3LICENSE = "BSD-2-Clause"
4HOMEPAGE = "http://dotat.at/prog/unifdef/"
5DESCRIPTION = "The unifdef utility selectively processes conditional C preprocessor #if and #ifdef directives. It removes from a file both the directives and the additional text that they delimit, while otherwise leaving the file alone."
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=3498caf346f6b77934882101749ada23 \
8                    file://unifdef.c;endline=32;md5=6f4ee8085d6e6ab0f7cb4390e1a9c497 \
9                    "
10
11SRC_URI = "http://dotat.at/prog/${BPN}/${BP}.tar.xz"
12SRC_URI[md5sum] = "ae8c0b3b4c43c1f6bc5f32412a820818"
13SRC_URI[sha256sum] = "43ce0f02ecdcdc723b2475575563ddb192e988c886d368260bc0a63aee3ac400"
14
15UPSTREAM_CHECK_REGEX = "unifdef-(?P<pver>((\d+\.*)+)(?![a-f0-9]{6,})).tar"
16
17do_install() {
18	oe_runmake install DESTDIR=${D} prefix=${prefix}
19}
20
21BBCLASSEXTEND = "native nativesdk"
22