1SUMMARY = "Userspace NFS server v3 protocol"
2DESCRIPTION = "UNFS3 is a user-space implementation of the NFSv3 server \
3specification. It provides a daemon for the MOUNT and NFS protocols, which \
4are used by NFS clients for accessing files on the server."
5HOMEPAGE = "https://github.com/unfs3/unfs3"
6SECTION = "console/network"
7LICENSE = "unfs3"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=9475885294e17c0cc0067820d042792e"
9
10DEPENDS = "flex-native bison-native flex"
11DEPENDS += "libtirpc"
12DEPENDS:append:class-nativesdk = " flex-nativesdk"
13
14S = "${WORKDIR}/git"
15SRC_URI = "git://github.com/unfs3/unfs3.git;protocol=https;branch=master \
16           file://0001-daemon.c-Fix-race-window-for-writing-of-the-pid-file.patch \
17           file://0001-Alias-off64_t-to-off_t-on-linux-if-not-defined.patch \
18           file://0001-locate.c-Include-attr.h.patch \
19           file://0001-fix-building-on-macOS.patch \
20           file://0001-attr-fix-utime-for-symlink.patch \
21           "
22SRCREV = "c8f2d2cd4529955419bad0e163f88d47ff176b8d"
23UPSTREAM_CHECK_GITTAGREGEX = "unfs3\-(?P<pver>\d+(\.\d+)+)"
24
25PV = "0.10.0"
26
27BBCLASSEXTEND = "native nativesdk"
28
29inherit autotools pkgconfig
30EXTRA_OECONF:append:class-native = " --sbindir=${bindir}"
31