1SUMMARY = "Userspace NFS server v3 protocol"
2DESCRIPTION = "UNFS3 is a user-space implementation of the NFSv3 server \
3specification. It provides a daemon for the MOUNT and NFS protocols, which \
4are used by NFS clients for accessing files on the server."
5HOMEPAGE = "https://github.com/unfs3/unfs3"
6SECTION = "console/network"
7LICENSE = "unfs3"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=9475885294e17c0cc0067820d042792e"
9
10DEPENDS = "flex-native bison-native flex"
11DEPENDS += "libtirpc"
12DEPENDS:append:class-nativesdk = " flex-nativesdk"
13
14ASNEEDED = ""
15
16S = "${WORKDIR}/git"
17SRC_URI = "git://github.com/unfs3/unfs3.git;protocol=https;branch=master \
18           file://unfs3_parallel_build.patch \
19           file://alternate_rpc_ports.patch \
20           file://fix_pid_race_parent_writes_child_pid.patch \
21           file://fix_compile_warning.patch \
22           file://rename_fh_cache.patch \
23           file://relative_max_socket_path_len.patch \
24           file://tcp_no_delay.patch \
25           file://0001-daemon.c-Libtirpc-porting-fixes.patch \
26           file://0001-attr-fix-utime-for-symlink.patch \
27           file://0001-Add-listen-action-for-a-tcp-socket.patch \
28           file://no-yywrap.patch \
29          "
30SRCREV = "c12a5c69a8d59be6916cbd0e0f41c159f1962425"
31UPSTREAM_CHECK_GITTAGREGEX = "unfs3\-(?P<pver>.+)"
32
33PV = "0.9.22+${SRCPV}"
34
35BBCLASSEXTEND = "native nativesdk"
36
37inherit autotools
38EXTRA_OECONF:append:class-native = " --sbindir=${bindir}"
39CFLAGS:append = " -I${STAGING_INCDIR}/tirpc"
40EXTRA_OECONF:append = " LIBS=-ltirpc"
41
42# Turn off these header detects else the inode search
43# will walk entire file systems and this is a real problem
44# if you have 2 TB of files to walk in your file system
45CACHED_CONFIGUREVARS = "ac_cv_header_mntent_h=no ac_cv_header_sys_mnttab_h=no"
46