1SUMMARY = "Rust standard libaries"
2HOMEPAGE = "http://www.rust-lang.org"
3SECTION = "devel"
4LICENSE = "(MIT | Apache-2.0) & Unicode-TOU"
5LIC_FILES_CHKSUM = "file://../../COPYRIGHT;md5=c2cccf560306876da3913d79062a54b9"
6
7require rust-source.inc
8
9# The dummy crate named `sysroot` represents the standard library target.
10#
11# See fd4c81f4c19e ("Add a `sysroot` crate to represent the standard library crates")
12# https://github.com/rust-lang/rust/pull/108865/
13S = "${RUSTSRC}/library/sysroot"
14
15RUSTLIB_DEP = ""
16inherit cargo
17
18DEPENDS:append:libc-musl = " libunwind"
19# rv32 does not have libunwind ported yet
20DEPENDS:remove:riscv32 = "libunwind"
21DEPENDS:remove:riscv64 = "libunwind"
22
23# Embed bitcode in order to allow compiling both with and without LTO
24RUSTFLAGS += "-Cembed-bitcode=yes"
25# Needed so cargo can find libbacktrace
26RUSTFLAGS += "-L ${STAGING_LIBDIR} -C link-arg=-Wl,-soname,libstd.so"
27
28CARGO_FEATURES ?= "panic-unwind backtrace"
29CARGO_BUILD_FLAGS += "--features '${CARGO_FEATURES}'"
30CARGO_VENDORING_DIRECTORY = "${RUSTSRC}/vendor"
31
32do_compile:prepend () {
33    export CARGO_TARGET_DIR="${B}"
34    # For Rust 1.13.0 and newer
35    export RUSTC_BOOTSTRAP="1"
36}
37
38do_install () {
39    mkdir -p ${D}${rustlibdir}
40
41    # With the incremental build support added in 1.24, the libstd deps directory also includes dependency
42    # files that get installed. Those are really only needed to incrementally rebuild the libstd library
43    # itself and don't need to be installed.
44    rm -f ${B}/${RUST_TARGET_SYS}/${BUILD_DIR}/deps/*.d
45    cp ${B}/${RUST_TARGET_SYS}/${BUILD_DIR}/deps/* ${D}${rustlibdir}
46}
47
48BBCLASSEXTEND = "nativesdk"
49
50# Since 1.70.0 upgrade this fails to build with gold:
51# http://errors.yoctoproject.org/Errors/Details/708194/
52# ld: error: version script assignment of  to symbol __rust_alloc_error_handler_should_panic failed: symbol not defined
53LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd', '', d)}"
54