1SUMMARY = "Runs postinstall scripts on first boot of the target device"
2DESCRIPTION = "${SUMMARY}"
3SECTION = "devel"
4PR = "r10"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8SRC_URI = "file://run-postinsts \
9           file://run-postinsts.init \
10           file://run-postinsts.service"
11
12S = "${WORKDIR}"
13
14inherit allarch systemd update-rc.d
15
16INITSCRIPT_NAME = "run-postinsts"
17INITSCRIPT_PARAMS = "start 99 S ."
18
19SYSTEMD_SERVICE:${PN} = "run-postinsts.service"
20
21do_configure() {
22	:
23}
24
25do_compile () {
26	:
27}
28
29do_install() {
30	install -d ${D}${sbindir}
31	install -m 0755 ${WORKDIR}/run-postinsts ${D}${sbindir}/
32
33	install -d ${D}${sysconfdir}/init.d/
34	install -m 0755 ${WORKDIR}/run-postinsts.init ${D}${sysconfdir}/init.d/run-postinsts
35
36	install -d ${D}${systemd_system_unitdir}/
37	install -m 0644 ${WORKDIR}/run-postinsts.service ${D}${systemd_system_unitdir}/
38
39	sed -i -e 's:#SYSCONFDIR#:${sysconfdir}:g' \
40               -e 's:#SBINDIR#:${sbindir}:g' \
41               -e 's:#BASE_BINDIR#:${base_bindir}:g' \
42               -e 's:#LOCALSTATEDIR#:${localstatedir}:g' \
43               ${D}${sbindir}/run-postinsts \
44               ${D}${systemd_system_unitdir}/run-postinsts.service
45}
46