1SUMMARY = "Helper utilities needed by the runqemu script"
2LICENSE = "GPL-2.0-only"
3RDEPENDS:${PN} = "qemu-system-native"
4
5LIC_FILES_CHKSUM = "file://${WORKDIR}/qemu-oe-bridge-helper.c;endline=4;md5=ae00a3bab86f2caaa8462eacda77f4d7"
6
7SRC_URI = "file://qemu-oe-bridge-helper.c"
8
9S = "${WORKDIR}"
10
11inherit native
12
13do_compile() {
14	${CC} ${CFLAGS} ${LDFLAGS} -Wall qemu-oe-bridge-helper.c -o qemu-oe-bridge-helper
15}
16
17do_install() {
18	install -d ${D}${bindir}
19	install qemu-oe-bridge-helper ${D}${bindir}/
20}
21
22DEPENDS += "qemu-system-native unfs3-native pseudo-native"
23addtask addto_recipe_sysroot after do_populate_sysroot before do_build
24